summaryrefslogtreecommitdiff
path: root/dev-libs/tre
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tre
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tre')
-rw-r--r--dev-libs/tre/Manifest1
-rw-r--r--dev-libs/tre/files/0.8.0-pkgcfg.patch14
-rw-r--r--dev-libs/tre/files/0.8.0-python.patch39
-rw-r--r--dev-libs/tre/metadata.xml5
-rw-r--r--dev-libs/tre/tre-0.8.0.ebuild90
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-libs/tre/Manifest b/dev-libs/tre/Manifest
new file mode 100644
index 00000000000..05c7989f7e1
--- /dev/null
+++ b/dev-libs/tre/Manifest
@@ -0,0 +1 @@
+DIST tre-0.8.0.tar.bz2 380714 SHA256 8dc642c2cde02b2dac6802cdbe2cda201daf79c4ebcbb3ea133915edf1636658 SHA512 db7465993e0d25eee8e52f974427b8a040234cf0f017769eb94ee88bc6261821336aad7f762bfa82db7e2212d8449bc221592586f061c528a59a550773cbc263 WHIRLPOOL 97146f193c828ce16d76fb6e181d5b91f5a26e1ebf73b0f17374b6826da471ec2f160cf640607cb00cbf217367dcf426b86159cbd229fed5801d09a3e39c923d
diff --git a/dev-libs/tre/files/0.8.0-pkgcfg.patch b/dev-libs/tre/files/0.8.0-pkgcfg.patch
new file mode 100644
index 00000000000..82f80350428
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-pkgcfg.patch
@@ -0,0 +1,14 @@
+ tre.pc.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tre.pc.in b/tre.pc.in
+index fdc45fa..b8d0676 100644
+--- a/tre.pc.in
++++ b/tre.pc.in
+@@ -6,5 +6,5 @@ includedir=@includedir@
+ Name: TRE
+ Description: TRE regexp matching library
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltre @LDFLAGS@ @LIBINTL@ @LIBS@
++Libs: -L${libdir} -ltre @LIBINTL@ @LIBS@
+ Cflags: -I${includedir} @CPPFLAGS@
diff --git a/dev-libs/tre/files/0.8.0-python.patch b/dev-libs/tre/files/0.8.0-python.patch
new file mode 100644
index 00000000000..f290e0bf578
--- /dev/null
+++ b/dev-libs/tre/files/0.8.0-python.patch
@@ -0,0 +1,39 @@
+diff --git a/python/setup.py b/python/setup.py
+index b420a4c..b1bca6b 100644
+--- a/python/setup.py
++++ b/python/setup.py
+@@ -10,7 +10,8 @@ import shutil
+
+ version = "0.8.0"
+ data_files = []
+-include_dirs = ["../lib"]
++include_dirs = ["lib"]
++library_dirs = ["lib/.libs"]
+ libraries = ["tre"]
+
+ if sys.platform == "win32":
+@@ -28,9 +29,10 @@ setup(name = "tre",
+ url = "http://laurikari.net/tre/",
+ data_files = data_files,
+ ext_modules = [Extension("tre",
+- sources = ["tre-python.c"],
++ sources = ["python/tre-python.c"],
+ define_macros = [("HAVE_CONFIG_H", None)],
+ include_dirs = include_dirs,
++ library_dirs = library_dirs,
+ libraries = libraries
+ ),
+ ],
+diff --git a/python/tre-python.c b/python/tre-python.c
+index bbb24ed..2e35e3a 100644
+--- a/python/tre-python.c
++++ b/python/tre-python.c
+@@ -13,7 +13,7 @@
+ #include "Python.h"
+ #include "structmember.h"
+
+-#include <tre/tre.h>
++#include <tre.h>
+
+ #define TRE_MODULE "tre"
+
diff --git a/dev-libs/tre/metadata.xml b/dev-libs/tre/metadata.xml
new file mode 100644
index 00000000000..f23b9cae159
--- /dev/null
+++ b/dev-libs/tre/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>
diff --git a/dev-libs/tre/tre-0.8.0.ebuild b/dev-libs/tre/tre-0.8.0.ebuild
new file mode 100644
index 00000000000..2cc01f1a9dc
--- /dev/null
+++ b/dev-libs/tre/tre-0.8.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Lightweight, robust, and efficient POSIX compliant regexp matching library"
+HOMEPAGE="http://laurikari.net/tre/"
+SRC_URI="http://laurikari.net/tre/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="nls python static-libs"
+
+RDEPEND="
+ !app-misc/glimpse
+ !app-text/agrep"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DISTUTILS_SETUP_FILES=("python/setup.py")
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-python.patch \
+ "${FILESDIR}"/${PV}-pkgcfg.patch
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-agrep \
+ --enable-system-abi \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die
+ use python && distutils_src_compile
+}
+
+src_test() {
+ if $(locale -a | grep -iq en_US.iso88591); then
+ emake -j1 \
+ check || die
+ else
+ ewarn "If you like to run the test,"
+ ewarn "please make sure en_US.ISO-8859-1 is installed."
+ die "en_US.ISO-8859-1 locale is missing"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ local exe_ext=
+ [[ ${CHOST} = *mingw32* ]] && exe_ext=.exe
+ mv "${ED}"/usr/bin/agrep{,-tre}${exe_ext} || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+ dohtml doc/*.{css,html} || die
+ use python && distutils_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "app-misc/glimpse, app-text/agrep and this package all provide agrep."
+ ewarn "If this causes any unforeseen incompatibilities please file a bug"
+ ewarn "on http://bugs.gentoo.org."
+ echo
+
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}