summaryrefslogtreecommitdiff
path: root/dev-libs/ucommon
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-18 14:55:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-18 14:55:59 +0200
commit8f44794b5ecfc9a34ac709d8a2a253260dedb410 (patch)
tree03cca983c0bd8812f8ca743aa7cbf76f61cf0db5 /dev-libs/ucommon
parentc030d441200f3ed0c35ea730c3cae7af68f68ced (diff)
downloadgentoo-8f44794b5ecfc9a34ac709d8a2a253260dedb410.tar.gz
gentoo-8f44794b5ecfc9a34ac709d8a2a253260dedb410.tar.xz
dev-libs/ucommon: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/ucommon')
-rw-r--r--dev-libs/ucommon/Manifest1
-rw-r--r--dev-libs/ucommon/ucommon-6.5.2.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/ucommon/Manifest b/dev-libs/ucommon/Manifest
index 2af3a37edb1..b023b5e222d 100644
--- a/dev-libs/ucommon/Manifest
+++ b/dev-libs/ucommon/Manifest
@@ -3,3 +3,4 @@ DIST ucommon-6.0.3.tar.gz 806841 SHA256 228f3a0fa78173e9fa43e154250a7ed4f1e5be72
DIST ucommon-6.1.10.tar.gz 833384 SHA256 d7a15ed31e3c418b41d95d5ff5e1bc24dfc4c2a465a099c6fd30e0b6c9f7be92 SHA512 6d6e716dcb71d6a4e49307baa0e9e62b4b50f3dbe8301eb93e3b562d94eb9ccee73a733928059a5ed97deba55c00308af0326a32cec6a73dbf7884c322177050 WHIRLPOOL 31666dc7e4c00b9acc7ba9d7a26033ec7ff28674722597e9677ba426b79fae45a170c5caaaa4066738d072090c2dacd465dc861aebbbd50cde36877b3b1a1e59
DIST ucommon-6.1.8.tar.gz 833017 SHA256 9a2b3eb0b71198adcccd74303df59551fdd016c3a2848fb8be003fb1ac2e7fc5 SHA512 86fcd9b2fbafd06d87470a16bc3d377716e7040f29ccb91bf1fbe9ce66ef88e936141bd7c388d4bb63b9d4dea5e22ec9a0aae39cf3cf58e8a0e3ac9cb9b546b4 WHIRLPOOL a87ae7a929920710ad601d04bbf907c626ca4ade92d19c18ac0cba004428505d52082742ff65a0ce00862f04507e69a31012a365ababdc9bbbf5b0866c557047
DIST ucommon-6.3.1.tar.gz 830661 SHA256 b59aa5414e756935ef9c479ece837f5700e4a5f39b0a016daa90528b175f59d5 SHA512 6f4832ac53aaf1456f2d913730b66588a89a3c1292fb79f3f56da466a2542af9c836579c0a3c4daf3f896a0c3e35f861b71514f960052adcb4e3abb872b781ec WHIRLPOOL 0bad6d56c0f1111a1aa15f7532ce6507be897a2b7ce27e452e71c08064f3f854b6864d3f7ed58ed476edf6777fc256374ab08e9c89bbb4f4abfcef8486969fed
+DIST ucommon-6.5.2.tar.gz 847128 SHA256 fbc929cafd5099a78978acde274849d70f4da554cee0d86865591b784f424622 SHA512 dc6dc048bad52d117edd1936ad31fd9fc6dba418fea3f7fd1578a96909c1eb53d2a42c4773a168db38ff24fc73b467ab30ec9b5ad5132ae473c36cea0e77b341 WHIRLPOOL d172311f7a13e48d99be5567f6f8ec2d806feea5b0a858fe7372cd024a10c676748c2533f9e1ac00093dbc3838fbf69c3c34e7d4a20709f1156c566ceabdf819
diff --git a/dev-libs/ucommon/ucommon-6.5.2.ebuild b/dev-libs/ucommon/ucommon-6.5.2.ebuild
new file mode 100644
index 00000000000..f84d38e1632
--- /dev/null
+++ b/dev-libs/ucommon/ucommon-6.5.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Portable C++ runtime for threads and sockets"
+HOMEPAGE="http://www.gnu.org/software/commoncpp"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc static-libs socks +cxx debug ssl gnutls"
+
+RDEPEND="
+ ssl? (
+ !gnutls? ( dev-libs/openssl:0= )
+ gnutls? (
+ net-libs/gnutls:0=
+ dev-libs/libgcrypt:0=
+ )
+ )"
+
+DEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
+PATCHES=(
+ "${FILESDIR}/6.1/install_gcrypt.m4_file.patch"
+ "${FILESDIR}/${PN}-6.3.1-gcrypt_autotools.patch"
+)
+
+# Needed for doxygen, bug #526726
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Aclocal 1.13 deprecated error BGO #467674
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
+ # don't install latex and rtf documents
+ sed -e '/^GENERATE_LATEX/s@YES@NO@' -e '/^GENERATE_RTF/s@YES@NO@' \
+ -i Doxyfile.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
+ fi
+
+ local myeconfargs=(
+ $(use_enable socks)
+ $(use_enable cxx stdcpp)
+ ${myconf}
+ --enable-atomics
+ --with-pkg-config
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxy
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}