summaryrefslogtreecommitdiff
path: root/dev-libs/ucommon
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-28 11:17:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-28 11:18:18 +0200
commitb2ebf832b3572a1842a5d6af574f076d5fec00fa (patch)
treef18921d8dcabc3104de9fd7c2f669d08bffa39e1 /dev-libs/ucommon
parentbd48e08d06772a4fd13c26bd05527bc8e9583aea (diff)
downloadgentoo-b2ebf832b3572a1842a5d6af574f076d5fec00fa.tar.gz
gentoo-b2ebf832b3572a1842a5d6af574f076d5fec00fa.tar.xz
dev-libs/ucommon: Bump to version 6.5.7
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/ucommon')
-rw-r--r--dev-libs/ucommon/Manifest1
-rw-r--r--dev-libs/ucommon/ucommon-6.5.7.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/ucommon/Manifest b/dev-libs/ucommon/Manifest
index d8f0c4c7e5d..c5186942713 100644
--- a/dev-libs/ucommon/Manifest
+++ b/dev-libs/ucommon/Manifest
@@ -3,3 +3,4 @@ DIST ucommon-6.0.3.tar.gz 806841 SHA256 228f3a0fa78173e9fa43e154250a7ed4f1e5be72
DIST ucommon-6.1.10.tar.gz 833384 SHA256 d7a15ed31e3c418b41d95d5ff5e1bc24dfc4c2a465a099c6fd30e0b6c9f7be92 SHA512 6d6e716dcb71d6a4e49307baa0e9e62b4b50f3dbe8301eb93e3b562d94eb9ccee73a733928059a5ed97deba55c00308af0326a32cec6a73dbf7884c322177050 WHIRLPOOL 31666dc7e4c00b9acc7ba9d7a26033ec7ff28674722597e9677ba426b79fae45a170c5caaaa4066738d072090c2dacd465dc861aebbbd50cde36877b3b1a1e59
DIST ucommon-6.3.1.tar.gz 830661 SHA256 b59aa5414e756935ef9c479ece837f5700e4a5f39b0a016daa90528b175f59d5 SHA512 6f4832ac53aaf1456f2d913730b66588a89a3c1292fb79f3f56da466a2542af9c836579c0a3c4daf3f896a0c3e35f861b71514f960052adcb4e3abb872b781ec WHIRLPOOL 0bad6d56c0f1111a1aa15f7532ce6507be897a2b7ce27e452e71c08064f3f854b6864d3f7ed58ed476edf6777fc256374ab08e9c89bbb4f4abfcef8486969fed
DIST ucommon-6.5.2.tar.gz 847128 SHA256 fbc929cafd5099a78978acde274849d70f4da554cee0d86865591b784f424622 SHA512 dc6dc048bad52d117edd1936ad31fd9fc6dba418fea3f7fd1578a96909c1eb53d2a42c4773a168db38ff24fc73b467ab30ec9b5ad5132ae473c36cea0e77b341 WHIRLPOOL d172311f7a13e48d99be5567f6f8ec2d806feea5b0a858fe7372cd024a10c676748c2533f9e1ac00093dbc3838fbf69c3c34e7d4a20709f1156c566ceabdf819
+DIST ucommon-6.5.7.tar.gz 855822 SHA256 3dedf94afe35e63b44a9a17cbc77a229e090fde1c56cd3476d936c44462404db SHA512 9927c9726252cdf050f217fa5993d34dcf9f76fab8399ee3a4c91cf087d9409947ed486a21e8448cb57ea95b52826682120f99d39287983c306434f9121b4d24 WHIRLPOOL b0c558eaff56e7f27b10b3ec6aeef514fe3c0898804953946f613449fbf4face8a421a2a047898f9ff1e1af96cb4b21a9064f8850a5df6b91213d4ec56afa98d
diff --git a/dev-libs/ucommon/ucommon-6.5.7.ebuild b/dev-libs/ucommon/ucommon-6.5.7.ebuild
new file mode 100644
index 00000000000..cf061aae629
--- /dev/null
+++ b/dev-libs/ucommon/ucommon-6.5.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Portable C++ runtime for threads and sockets"
+HOMEPAGE="https://www.gnu.org/software/commoncpp"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc static-libs socks +cxx debug ssl gnutls"
+
+RDEPEND="
+ ssl? (
+ !gnutls? ( dev-libs/openssl:0= )
+ gnutls? (
+ net-libs/gnutls:0=
+ dev-libs/libgcrypt:0=
+ )
+ )"
+
+DEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
+PATCHES=(
+ "${FILESDIR}/6.1/install_gcrypt.m4_file.patch"
+ "${FILESDIR}/${PN}-6.3.1-gcrypt_autotools.patch"
+)
+
+# Needed for doxygen, bug #526726
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Aclocal 1.13 deprecated error BGO #467674
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
+ # don't install latex and rtf documents
+ sed -e '/^GENERATE_LATEX/s@YES@NO@' -e '/^GENERATE_RTF/s@YES@NO@' \
+ -i Doxyfile.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
+ fi
+
+ local myeconfargs=(
+ $(use_enable socks)
+ $(use_enable cxx stdcpp)
+ ${myconf}
+ --enable-atomics
+ --with-pkg-config
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxy
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}