summaryrefslogtreecommitdiff
path: root/dev-libs/uulib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/uulib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/uulib')
-rw-r--r--dev-libs/uulib/Manifest1
-rw-r--r--dev-libs/uulib/files/uulib-0.5.20-shared.patch83
-rw-r--r--dev-libs/uulib/metadata.xml8
-rw-r--r--dev-libs/uulib/uulib-0.5.20-r1.ebuild26
-rw-r--r--dev-libs/uulib/uulib-0.5.20.ebuild31
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-libs/uulib/Manifest b/dev-libs/uulib/Manifest
new file mode 100644
index 00000000000..f47afed0cc0
--- /dev/null
+++ b/dev-libs/uulib/Manifest
@@ -0,0 +1 @@
+DIST uudeview-0.5.20.tar.gz 261574 SHA256 e49a510ddf272022af204e96605bd454bb53da0b3fe0be437115768710dae435 SHA512 d080e9c3940bad7bacd28457f21133056384a01e33ba014de42502d23f81f2c7f5fa7f6c472ce9f37bec2edb8e18d27135bf18426cf2f23188a3683558e1721c WHIRLPOOL 4c18f8b1930852c89d2d0ca31e64d3eb06c19cef58d0901e3cafe0ae73b1245b749e7548d1726f772a631c2ffa2ad15b815861ab6dc779e8184334948c149326
diff --git a/dev-libs/uulib/files/uulib-0.5.20-shared.patch b/dev-libs/uulib/files/uulib-0.5.20-shared.patch
new file mode 100644
index 00000000000..3a7f6582ef4
--- /dev/null
+++ b/dev-libs/uulib/files/uulib-0.5.20-shared.patch
@@ -0,0 +1,83 @@
+Source: PDL Linux
+https://raw.githubusercontent.com/pld-linux/uudeview/master/uudeview-shared.patch
+https://github.com/pld-linux/uudeview
+
+
+diff -ruN uudeview-0.5.20.orig/uulib/Makefile.in uudeview-0.5.20/uulib/Makefile.in
+--- uudeview-0.5.20.orig/uulib/Makefile.in 2002-03-11 10:15:46.000000000 +0100
++++ uudeview-0.5.20/uulib/Makefile.in 2014-10-11 20:20:04.280175737 +0200
+@@ -40,9 +40,13 @@
+ VDEF = -DVERSION=\"$(VERSION)\" -DPATCH=\"$(PATCH)\"
+ #
+
++DESTDIR =
++libdir = @libdir@
++includedir = @prefix@/@includedir@
++
+ UULIB_SOURCE = uulib.c uucheck.c uunconc.c uuutil.c uuencode.c \
+ uuscan.c uustring.c fptools.c crc32.c
+-UULIB_OBJ = ${UULIB_SOURCE:.c=.o}
++UULIB_OBJ = ${UULIB_SOURCE:.c=.lo}
+
+ #
+ # make stuff
+@@ -51,11 +55,11 @@
+ .SUFFIXES:
+ .SUFFIXES: .c .o
+
+-all: libuu.a
++all: libuu.la
+
+ clean:
+ rm -f [Xx]deview gif2gfp
+- rm -f *.o *.a *.so core *~ TAGS
++ rm -f *.o *.a *.so core *~ TAGS *.lo *.la
+
+ distclean: clean
+ rm -f config.status config.cache config.log Makefile config.h
+@@ -64,25 +68,28 @@
+ realclean: distclean
+
+ new: clean
+- rm -f libuu.a
++ rm -f libuu.la
+ $(MAKE) all
+
+-libuu.a: $(UULIB_OBJ)
+- rm -f $@
+- ar r $@ $(UULIB_OBJ)
+- -$(RANLIB) $@
+-
+-.c.o:
+- $(CC) -c $(CFLAGS) $(VDEF) $<
+-
+-uuencode.o: uuencode.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uulib.o: uulib.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uunconc.o: uunconc.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uucheck.o: uucheck.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uuutil.o: uuutil.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uuscan.o: uuutil.c uudeview.h uuint.h uustring.h fptools.h config.h
+-uustring.o: uustring.c uudeview.h uuint.h uustring.h config.h
+-fptools.o: fptools.c fptools.h config.h
++libuu.la: $(UULIB_OBJ)
++ libtool --mode=link $(CC) -o libuu.la $(LDFLAGS) $(UULIB_OBJ) -rpath $(libdir)
++
++%.lo : %.c
++ libtool --mode=compile $(CC) -c $(CFLAGS) $(VDEF) $<
++
++install: libuu.la
++ install -d $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
++ libtool --mode=install install libuu.la $(DESTDIR)$(libdir)
++ install uudeview.h fptools.h $(DESTDIR)$(includedir)
++
++uuencode.lo: uuencode.c uudeview.h uuint.h uustring.h fptools.h config.h
++uulib.lo: uulib.c uudeview.h uuint.h uustring.h fptools.h config.h
++uunconc.lo: uunconc.c uudeview.h uuint.h uustring.h fptools.h config.h
++uucheck.lo: uucheck.c uudeview.h uuint.h uustring.h fptools.h config.h
++uuutil.lo: uuutil.c uudeview.h uuint.h uustring.h fptools.h config.h
++uuscan.lo: uuutil.c uudeview.h uuint.h uustring.h fptools.h config.h
++uustring.lo: uustring.c uudeview.h uuint.h uustring.h config.h
++fptools.lo: fptools.c fptools.h config.h
+
+ uustring.h: uustring.c
+ awk -f uustring.awk < uustring.c > uustring.h
diff --git a/dev-libs/uulib/metadata.xml b/dev-libs/uulib/metadata.xml
new file mode 100644
index 00000000000..cc074c683a6
--- /dev/null
+++ b/dev-libs/uulib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>library that supports Base64 (MIME), uuencode, xxencode and binhex coding</longdescription>
+</pkgmetadata>
diff --git a/dev-libs/uulib/uulib-0.5.20-r1.ebuild b/dev-libs/uulib/uulib-0.5.20-r1.ebuild
new file mode 100644
index 00000000000..1ba2403bfc0
--- /dev/null
+++ b/dev-libs/uulib/uulib-0.5.20-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P=uudeview-${PV}
+
+DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-shared.patch"
+ sed -i 's:\<ar\>:$(AR):' Makefile.in || die
+ tc-export AR CC RANLIB
+}
diff --git a/dev-libs/uulib/uulib-0.5.20.ebuild b/dev-libs/uulib/uulib-0.5.20.ebuild
new file mode 100644
index 00000000000..c946422c27f
--- /dev/null
+++ b/dev-libs/uulib/uulib-0.5.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+MY_P=uudeview-${PV}
+
+DESCRIPTION="Library that supports Base64 (MIME), uuencode, xxencode and binhex coding"
+HOMEPAGE="http://www.fpx.de/fp/Software/UUDeview/"
+SRC_URI="http://www.fpx.de/fp/Software/UUDeview/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}/${PN}
+
+src_prepare() {
+ sed -i 's:\<ar\>:$(AR):' Makefile.in || die
+ tc-export AR CC RANLIB
+}
+
+src_install() {
+ dolib.a libuu.a
+ insinto /usr/include
+ doins uudeview.h
+}