summaryrefslogtreecommitdiff
path: root/dev-libs/wlc
diff options
context:
space:
mode:
authorJasen Borisov <tajjada@gmail.com>2016-05-12 11:08:10 +0100
committerIan Delaney <idella4@gentoo.org>2016-05-13 11:34:40 +0800
commit91273e7f5354dc3a5e1290192044557191db931f (patch)
tree6be0ec8fbc15bb4acb8aa93b5ddfd526a2d8be36 /dev-libs/wlc
parentf0379d748e8ce0e69db1fb7bd077cdb31ed56838 (diff)
downloadgentoo-91273e7f5354dc3a5e1290192044557191db931f.tar.gz
gentoo-91273e7f5354dc3a5e1290192044557191db931f.tar.xz
dev-libs/wlc: add postinst message about Xwayland.
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1459 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/wlc-0.0.2.ebuild10
-rw-r--r--dev-libs/wlc/wlc-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-libs/wlc/wlc-0.0.2.ebuild b/dev-libs/wlc/wlc-0.0.2.ebuild
index 72f4ddd828b..8917c648a1c 100644
--- a/dev-libs/wlc/wlc-0.0.2.ebuild
+++ b/dev-libs/wlc/wlc-0.0.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit cmake-utils
-DESCRIPTION="A helper library for Wayland compositors."
+DESCRIPTION="A helper library for Wayland compositors"
HOMEPAGE="https://github.com/Cloudef/wlc"
SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
@@ -48,3 +48,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}
diff --git a/dev-libs/wlc/wlc-9999.ebuild b/dev-libs/wlc/wlc-9999.ebuild
index 8af28d5b7c4..55443ba35d4 100644
--- a/dev-libs/wlc/wlc-9999.ebuild
+++ b/dev-libs/wlc/wlc-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit git-r3 cmake-utils
-DESCRIPTION="A helper library for Wayland compositors."
+DESCRIPTION="A helper library for Wayland compositors"
HOMEPAGE="https://github.com/Cloudef/wlc"
EGIT_REPO_URI="https://github.com/Cloudef/wlc.git"
@@ -48,3 +48,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}