summaryrefslogtreecommitdiff
path: root/dev-libs/wlc
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-11-04 20:52:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-11-04 23:23:04 +0100
commite366d8cd7eb95abaaff29f6e19a65a97dd4685b2 (patch)
tree4e784e05e690798601950f430ac9aa71c5acbccd /dev-libs/wlc
parent6d5c5658729d3f0fc3cf783b416545b8b313a7ec (diff)
downloadgentoo-e366d8cd7eb95abaaff29f6e19a65a97dd4685b2.tar.gz
gentoo-e366d8cd7eb95abaaff29f6e19a65a97dd4685b2.tar.xz
dev-libs/wlc: introduce xwayland use flag.
Closes: https://github.com/gentoo/gentoo/pull/2744 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/metadata.xml1
-rw-r--r--dev-libs/wlc/wlc-9999.ebuild8
2 files changed, 5 insertions, 4 deletions
diff --git a/dev-libs/wlc/metadata.xml b/dev-libs/wlc/metadata.xml
index bd85b2b7a6a..3319b29914b 100644
--- a/dev-libs/wlc/metadata.xml
+++ b/dev-libs/wlc/metadata.xml
@@ -12,5 +12,6 @@
<use>
<flag name="systemd">Enable support for systemd-logind.</flag>
<flag name="X">Enable X11 backend and XWayland support.</flag>
+ <flag name="xwayland">Enable XWayland support.</flag>
</use>
</pkgmetadata>
diff --git a/dev-libs/wlc/wlc-9999.ebuild b/dev-libs/wlc/wlc-9999.ebuild
index 5a3e040fbf8..e44e750107d 100644
--- a/dev-libs/wlc/wlc-9999.ebuild
+++ b/dev-libs/wlc/wlc-9999.ebuild
@@ -14,7 +14,7 @@ EGIT_REPO_URI="https://github.com/Cloudef/wlc.git"
LICENSE="MIT ZLIB"
SLOT="0"
KEYWORDS=""
-IUSE="X static-libs systemd"
+IUSE="X static-libs systemd xwayland"
RDEPEND="virtual/opengl
media-libs/mesa[wayland,gbm,gles2,egl]
@@ -29,6 +29,7 @@ RDEPEND="virtual/opengl
x11-libs/xcb-util-image
x11-libs/xcb-util-wm
x11-libs/libXfixes )
+ xwayland? ( x11-base/xorg-server[wayland] )
systemd? ( sys-apps/systemd sys-apps/dbus )"
DEPEND="${RDEPEND}
@@ -52,9 +53,8 @@ src_configure() {
}
pkg_postinst() {
- if use X && !has_version 'x11-base/xorg-server[wayland]'
+ if use X && !use xwayland
then
- elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
- elog "'x11-base/xorg-server[wayland]'."
+ elog "xwayland use flag is required for X11 applications support"
fi
}