summaryrefslogtreecommitdiff
path: root/dev-libs/xmlrpc-c
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2016-10-31 04:21:16 -0400
committerPatrice Clement <monsieurp@gentoo.org>2016-11-22 18:18:53 +0100
commit038c196811c98cec7f210191dca3316099238209 (patch)
tree2853e7a4907d19b0d86ad48bd4feae6e8c5535fb /dev-libs/xmlrpc-c
parent6ab65f73b3551029fe5ab7210d3378c757bfa143 (diff)
downloadgentoo-038c196811c98cec7f210191dca3316099238209.tar.gz
gentoo-038c196811c98cec7f210191dca3316099238209.tar.xz
dev-libs/xmlrpc-c: version bump to 1.39.11.
* EAPI=6 * Notes about upstream releases Closes: https://github.com/gentoo/gentoo/pull/2811
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/Manifest1
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/Manifest b/dev-libs/xmlrpc-c/Manifest
index 75c7ec17e7d..64cd148b9b1 100644
--- a/dev-libs/xmlrpc-c/Manifest
+++ b/dev-libs/xmlrpc-c/Manifest
@@ -1 +1,2 @@
DIST xmlrpc-c-1.32.05.tar.gz 769040 SHA256 cefd25dcb90556c90358cb44013a644f1aeafd37d2e18be37e66a3355b5ae0d2 SHA512 40813ad97010684e346ce4f286d9d7314547572f8681cf99d4c3c36cb7aa38b1cb72b84d63ab46e44282dc2bd95b85dbb022e3039700caa939469c6f7bf08d1f WHIRLPOOL 1e6ebbc1b3caa78e1e22210d81a61b74d71f61a33d1ea97f96ef250a5277d3cbe6d532d286bed8bb57e1ba4ccb54fd38bdf51f8d3bdbba00225bb5678de17292
+DIST xmlrpc-c-1.39.11.tgz 815463 SHA256 2e56cdcdd5c5fa564bcdc7a56bca108a88f5b78b34ccc85558366efabdc8b8e8 SHA512 13e7ddf5264436671437c0bcd698380baca35c4469f592edf79cb4cafda254fe8207ecb992ee728ed20ec70457a20bd0cf8e180ce5cf0561a38a21f1e588f584 WHIRLPOOL 40a85e66777caf3be49c00c62a4b577928255687fef7c67482c55c39bb56b4a7b0ba32b2e982813bed842ad689d2d95acbeb9aa9ddc77808e80cb1b31569ffb7
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild
new file mode 100644
index 00000000000..916292bddda
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.39.11.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Upstream maintains 3 release channels: http://xmlrpc-c.sourceforge.net/release.html
+# 1. Only the "Super Stable" series is released as a tarball
+# 2. SVN tagging of releases seems spotty: http://svn.code.sf.net/p/xmlrpc-c/code/release_number/
+# Because of this, we are following the "Super Stable" release channel
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="abyss +cgi +curl +cxx +libxml2 threads test tools"
+
+REQUIRED_USE="test? ( abyss curl cxx ) tools? ( curl )"
+
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ curl? ( net-misc/curl )
+ libxml2? ( dev-libs/libxml2 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be built"
+}
+
+src_configure() {
+ econf \
+ --disable-wininet-client \
+ --disable-libwww-client \
+ --without-libwww-ssl \
+ $(use_enable libxml2 libxml2-backend) \
+ $(use_enable threads abyss-threads) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable curl curl-client)
+}
+
+src_compile() {
+ # Parallel builds are fixed in v 1.43.x or newer
+ emake -j1
+ use tools && emake -rC "${S}"/tools
+}
+
+src_install() {
+ default
+ use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
+}