summaryrefslogtreecommitdiff
path: root/dev-libs/xmlrpc-c
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/xmlrpc-c
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/xmlrpc-c')
-rw-r--r--dev-libs/xmlrpc-c/Manifest1
-rw-r--r--dev-libs/xmlrpc-c/files/xmlrpc-c-1.32.05-Wimplicit.patch20
-rw-r--r--dev-libs/xmlrpc-c/metadata.xml14
-rw-r--r--dev-libs/xmlrpc-c/xmlrpc-c-1.32.05-r1.ebuild100
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-libs/xmlrpc-c/Manifest b/dev-libs/xmlrpc-c/Manifest
new file mode 100644
index 00000000000..75c7ec17e7d
--- /dev/null
+++ b/dev-libs/xmlrpc-c/Manifest
@@ -0,0 +1 @@
+DIST xmlrpc-c-1.32.05.tar.gz 769040 SHA256 cefd25dcb90556c90358cb44013a644f1aeafd37d2e18be37e66a3355b5ae0d2 SHA512 40813ad97010684e346ce4f286d9d7314547572f8681cf99d4c3c36cb7aa38b1cb72b84d63ab46e44282dc2bd95b85dbb022e3039700caa939469c6f7bf08d1f WHIRLPOOL 1e6ebbc1b3caa78e1e22210d81a61b74d71f61a33d1ea97f96ef250a5277d3cbe6d532d286bed8bb57e1ba4ccb54fd38bdf51f8d3bdbba00225bb5678de17292
diff --git a/dev-libs/xmlrpc-c/files/xmlrpc-c-1.32.05-Wimplicit.patch b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.32.05-Wimplicit.patch
new file mode 100644
index 00000000000..affa917f742
--- /dev/null
+++ b/dev-libs/xmlrpc-c/files/xmlrpc-c-1.32.05-Wimplicit.patch
@@ -0,0 +1,20 @@
+--- a/common.mk
++++ b/common.mk
+@@ -17,7 +17,7 @@
+ # fully made.
+ .DELETE_ON_ERROR:
+
+-GCC_WARNINGS = -Wall -W -Wno-uninitialized -Wundef -Wimplicit \
++GCC_WARNINGS = -Wall -W -Wno-uninitialized -Wundef \
+ -Wno-unknown-pragmas
+ # We need -Wwrite-strings after we fix all the missing consts
+ #
+@@ -27,7 +27,7 @@
+ # on -Wuninitialized for all the others.
+
+ GCC_C_WARNINGS = $(GCC_WARNINGS) \
+- -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes
++ -Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes -Wimplicit
+
+ GCC_CXX_WARNINGS = $(GCC_WARNINGS) -Wsynth
+
diff --git a/dev-libs/xmlrpc-c/metadata.xml b/dev-libs/xmlrpc-c/metadata.xml
new file mode 100644
index 00000000000..8be0201c8ad
--- /dev/null
+++ b/dev-libs/xmlrpc-c/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <use>
+ <flag name='abyss'>Build the Abyss mini web-server.</flag>
+ <flag name='libxml2'>Use dev-libs/libxml2 to parse XML instead of the internal expat library.</flag>
+ <flag name='threads'>Controls whether to build the Abyss web-server with pthreads or fork 'threading'.</flag>
+ <flag name='tools'>Build the xmlrpc* tools.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-libs/xmlrpc-c/xmlrpc-c-1.32.05-r1.ebuild b/dev-libs/xmlrpc-c/xmlrpc-c-1.32.05-r1.ebuild
new file mode 100644
index 00000000000..f21d5f19d5b
--- /dev/null
+++ b/dev-libs/xmlrpc-c/xmlrpc-c-1.32.05-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib
+
+# Maintainer notes: Take a look at http://xmlrpc-c.sourceforge.net/release.html
+# We use "advanced" branch, so for the current release revision take look here:
+# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced/version.mk?view=log
+# e.g. for 1.27.05 corresponds following revision 2182 and thus following URL:
+# http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced.tar.gz?view=tar&pathrev=2182
+# Note: autogenerated tarball checksum changes every download, thus download it
+# manually and distribute on mirrors.
+# It's possible to build net-libs/libwww without ssl support, but taking into
+# account that libwww is not really well maintained and upstream is dead we
+# better use it only in case ssl is required.
+
+DESCRIPTION="A lightweigt RPC library based on XML and HTTP"
+HOMEPAGE="http://xmlrpc-c.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~maksbotan/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="abyss +cgi +curl +cxx +libxml2 static-libs threads test tools"
+
+REQUIRED_USE="test? ( static-libs abyss curl cxx ) tools? ( curl )"
+
+DEPEND="
+ sys-libs/ncurses
+ sys-libs/readline
+ curl? ( net-misc/curl )
+ libxml2? ( dev-libs/libxml2 )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/advanced"
+
+pkg_setup() {
+ use curl || ewarn "Curl support disabled: No client library will be built"
+}
+
+#Bug 214137: We need to filter this.
+unset SRCDIR
+
+# Bug 255440
+export LC_ALL=C
+export LANG=C
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.32.05-Wimplicit.patch
+ sed -i \
+ -e "/CFLAGS_COMMON/s|-g -O3$||" \
+ -e "/CXXFLAGS_COMMON/s|-g$||" \
+ "${S}"/common.mk || die
+
+ export LADD=${LDFLAGS} # Respect the user's LDFLAGS.
+
+ use static-libs || { sed \
+ -e '/\(^TARGET_STATIC_LIBRARIES =\)/{s:\(^TARGET_STATIC_LIBRARIES =\).*:\1:;P;N;d;}' \
+ -i common.mk || die; }
+}
+
+src_configure() {
+ #Disable libwww support due GBZ #409549 and #320253
+
+ econf --disable-wininet-client \
+ $(use_enable libxml2 libxml2-backend) \
+ --disable-libwww-client \
+ --without-libwww-ssl \
+ $(use_enable threads abyss-threads) \
+ $(use_enable cgi cgi-server) \
+ $(use_enable abyss abyss-server) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable curl curl-client)
+}
+
+src_compile() {
+ emake -r
+ use tools && emake -rC "${S}"/tools
+}
+
+src_install() {
+ default_src_install
+ use tools && emake DESTDIR="${D}" -rC "${S}"/tools install
+}
+
+src_test() {
+ unset LDFLAGS LADD SRCDIR
+ cd "${S}"/test/
+ einfo "Building general tests"
+ make || die "Make of general tests failed"
+ einfo "Running general tests"
+ ./test || die "General tests failed"
+ cd "${S}"/test/cpp/
+ einfo "Running C++ tests"
+ ./test || die "C++ tests failed"
+}