summaryrefslogtreecommitdiff
path: root/dev-libs/xxl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/xxl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/xxl')
-rw-r--r--dev-libs/xxl/Manifest1
-rw-r--r--dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch12
-rw-r--r--dev-libs/xxl/metadata.xml8
-rw-r--r--dev-libs/xxl/xxl-1.0.1-r1.ebuild33
-rw-r--r--dev-libs/xxl/xxl-1.0.1.ebuild26
5 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/xxl/Manifest b/dev-libs/xxl/Manifest
new file mode 100644
index 00000000000..58c0e53dc61
--- /dev/null
+++ b/dev-libs/xxl/Manifest
@@ -0,0 +1 @@
+DIST xxl-1.0.1.tar.gz 456048 SHA256 7decbada52dabb0f7298b36982371c7ba4d817b281797498d0515ec2440b20f9 SHA512 fd7d16ed3a077f5c0d938e7ecf0357fbfa5c63ade835ef6e0672c032542db9aa921f8a14ffdff88c2df09700e0868e818ffc240a9f21d75571682295a407ca71 WHIRLPOOL c2ce9290869ff7865070ad60551121034a1faa7bf61db5c1acb879d1a1f7452af8c69b5a45caabe6280505b5b659367d40fed154f112cdf481fb6ce1f7197904
diff --git a/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch b/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch
new file mode 100644
index 00000000000..c6d52c5a09d
--- /dev/null
+++ b/dev-libs/xxl/files/xxl-1.0.1-nested-exception.patch
@@ -0,0 +1,12 @@
+diff -Naur xxl-1.0.1-orig/xxl.c xxl-1.0.1/xxl.c
+--- xxl-1.0.1-orig/xxl.c 2004-12-22 03:42:52.000000000 -0600
++++ xxl-1.0.1/xxl.c 2008-01-17 13:25:18.000000000 -0600
+@@ -380,6 +380,8 @@
+ if (!tsd->contexts)
+ die("XXL: Exception thrown with no handler to catch it!\n");
+ tsd->contexts->exception = *exception;
++ how=XXL_SETJMP_TRY;
++ tsd->contexts->state |= XXL_STATE_THROWN;
+ xxl_leave_handler(how);
+ return;
+ }
diff --git a/dev-libs/xxl/metadata.xml b/dev-libs/xxl/metadata.xml
new file mode 100644
index 00000000000..e96e35b1a37
--- /dev/null
+++ b/dev-libs/xxl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/dev-libs/xxl/xxl-1.0.1-r1.ebuild b/dev-libs/xxl/xxl-1.0.1-r1.ebuild
new file mode 100644
index 00000000000..b223ce77e51
--- /dev/null
+++ b/dev-libs/xxl/xxl-1.0.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="C/C++ library that provides exception handling and asset management"
+HOMEPAGE="http://www.zork.org/xxl/"
+SRC_URI="http://www.zork.org/software/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads static-libs"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nested-exception.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/xxl/xxl-1.0.1.ebuild b/dev-libs/xxl/xxl-1.0.1.ebuild
new file mode 100644
index 00000000000..25a1f415fab
--- /dev/null
+++ b/dev-libs/xxl/xxl-1.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="C/C++ library that provides exception handling and asset management"
+HOMEPAGE="http://www.zork.org/xxl/"
+SRC_URI="http://www.zork.org/software/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-nested-exception.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}