summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-11 20:47:40 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-11 20:50:03 +0200
commit3f50a2904e432a6377de4a421cf2762894413a99 (patch)
tree848c56bfeb0abd7926feecff5f5c125a37d7ac7f /dev-libs
parent5f7630b583a15ffdbed2aad53249021374be8801 (diff)
downloadgentoo-3f50a2904e432a6377de4a421cf2762894413a99.tar.gz
gentoo-3f50a2904e432a6377de4a421cf2762894413a99.tar.xz
dev-libs/libnl: Add dev-lang/python:3.5 support.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/libnl-3.2.28.ebuild21
-rw-r--r--dev-libs/libnl/libnl-3.2.9999.ebuild30
2 files changed, 33 insertions, 18 deletions
diff --git a/dev-libs/libnl/libnl-3.2.28.ebuild b/dev-libs/libnl/libnl-3.2.28.ebuild
index b592205c21f..7137235ccf3 100644
--- a/dev-libs/libnl/libnl-3.2.28.ebuild
+++ b/dev-libs/libnl/libnl-3.2.28.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
DISTUTILS_OPTIONAL=1
inherit distutils-r1 eutils libtool multilib multilib-minimal
@@ -21,20 +21,27 @@ SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="static-libs python utils"
-RDEPEND="python? ( ${PYTHON_DEPS} )
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r5
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-DEPEND="${RDEPEND}
+ )
+"
+DEPEND="
+ ${RDEPEND}
python? ( dev-lang/swig )
- sys-devel/flex
sys-devel/bison
+ sys-devel/flex
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
-DOCS=( ChangeLog )
+DOCS=(
+ ChangeLog
+)
S=${WORKDIR}/${LIBNL_P}
diff --git a/dev-libs/libnl/libnl-3.2.9999.ebuild b/dev-libs/libnl/libnl-3.2.9999.ebuild
index 08d97450a1d..dd182bb7be9 100644
--- a/dev-libs/libnl/libnl-3.2.9999.ebuild
+++ b/dev-libs/libnl/libnl-3.2.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
DISTUTILS_OPTIONAL=1
inherit autotools distutils-r1 eutils git-r3 libtool multilib multilib-minimal
@@ -17,20 +17,30 @@ SLOT="3"
KEYWORDS=""
IUSE="static-libs python utils"
-RDEPEND="python? ( ${PYTHON_DEPS} )
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r5
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-DEPEND="${RDEPEND}
+ )
+"
+DEPEND="
+ ${RDEPEND}
python? ( dev-lang/swig )
- sys-devel/flex
sys-devel/bison
+ sys-devel/flex
"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DOCS=( ChangeLog )
+DOCS=(
+ ChangeLog
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-vlan-header.patch
+ "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
+ "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
+)
MULTILIB_WRAPPED_HEADERS=(
# we do not install CLI stuff for non-native
@@ -49,9 +59,7 @@ MULTILIB_WRAPPED_HEADERS=(
)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1-vlan-header.patch
- epatch "${FILESDIR}"/${PN}-3.2.20-rtnl_tc_get_ops.patch
- epatch "${FILESDIR}"/${PN}-3.2.20-cache-api.patch
+ default
eautoreconf