summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorJohan Bergström <bugs@bergstroem.nu>2016-02-09 08:53:44 +1100
committerJohan Bergström <bugs@bergstroem.nu>2016-02-09 08:53:44 +1100
commit66973a2eb514ce7bed31ed2799934c80c59c9c34 (patch)
tree4eb77f5b802e3f9a2edf491e833f49bb7cda2e2c /dev-libs
parentc99f5cf50b84b14bd6f0f47e45321dd31a7fe017 (diff)
downloadgentoo-66973a2eb514ce7bed31ed2799934c80c59c9c34.tar.gz
gentoo-66973a2eb514ce7bed31ed2799934c80c59c9c34.tar.xz
dev-libs/{lib,}ucl: Avoid simultaneous installation
Both libraries opts to use /usr/{include,lib}/libucl* which leads to a conflict. There unfortunately doesn't seem to be a resolution upstream; dev-libs/ucl is 12 years old and dev-libs/libucl has stated that no changes related to this will occur.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libucl/libucl-0.7.3.ebuild3
-rw-r--r--dev-libs/ucl/ucl-1.03-r1.ebuild4
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-libs/libucl/libucl-0.7.3.ebuild b/dev-libs/libucl/libucl-0.7.3.ebuild
index 585a76baa97..ca66ff3056e 100644
--- a/dev-libs/libucl/libucl-0.7.3.ebuild
+++ b/dev-libs/libucl/libucl-0.7.3.ebuild
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="lua +regex signatures static-libs urlfetch utils"
-DEPEND="lua? ( >=dev-lang/lua-5.1:= )
+DEPEND="!!dev-libs/ucl
+ lua? ( >=dev-lang/lua-5.1:= )
signatures? ( dev-libs/openssl:0 )
urlfetch? ( net-misc/curl )"
RDEPEND="${DEPEND}"
diff --git a/dev-libs/ucl/ucl-1.03-r1.ebuild b/dev-libs/ucl/ucl-1.03-r1.ebuild
index 906fda7117a..49083baea20 100644
--- a/dev-libs/ucl/ucl-1.03-r1.ebuild
+++ b/dev-libs/ucl/ucl-1.03-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,6 +14,8 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="static-libs"
+DEPEND="!!dev-libs/libucl"
+
src_prepare() {
epatch "${FILESDIR}"/${P}-CFLAGS.patch
epatch "${FILESDIR}"/${P}-x32.patch #426334