summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-03-31 00:49:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-03-31 00:49:53 +0200
commitc1046df9aeef2b48b34953947275210872ec424c (patch)
treecb36b66932acfce29696d02d801a3c7096251f73 /dev-libs
parent838c3028555eb9d8f12017dcf43f0c7b0c8af90f (diff)
downloadgentoo-c1046df9aeef2b48b34953947275210872ec424c.tar.gz
gentoo-c1046df9aeef2b48b34953947275210872ec424c.tar.xz
dev-libs/boost: Add boost::graph patch
* Modify patches such that all apply with -p1 * Move patches into PATCHES variable, avoid epatch * Fix unquoted variable Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/boost-1.60.0.ebuild26
-rw-r--r--dev-libs/boost/files/boost-1.48.0-disable_icu_rpath.patch4
-rw-r--r--dev-libs/boost/files/boost-1.48.0-disable_libboost_python3.patch4
-rw-r--r--dev-libs/boost/files/boost-1.48.0-no_strict_aliasing_python2.patch4
-rw-r--r--dev-libs/boost/files/boost-1.48.0-python_linking.patch4
-rw-r--r--dev-libs/boost/files/boost-1.51.0-respect_python-buildid.patch12
-rw-r--r--dev-libs/boost/files/boost-1.51.0-support_dots_in_python-buildid.patch8
-rw-r--r--dev-libs/boost/files/boost-1.56.0-build-auto_index-tool.patch4
-rw-r--r--dev-libs/boost/files/boost-1.60.0-deprecated-header-ice_not.patch42
9 files changed, 76 insertions, 32 deletions
diff --git a/dev-libs/boost/boost-1.60.0.ebuild b/dev-libs/boost/boost-1.60.0.ebuild
index ea0fdc1077f..1a95c5eee8b 100644
--- a/dev-libs/boost/boost-1.60.0.ebuild
+++ b/dev-libs/boost/boost-1.60.0.ebuild
@@ -42,6 +42,18 @@ S="${WORKDIR}/${MY_P}"
# there is no point in having them in the ebuild to begin with.
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.51.0-respect_python-buildid.patch"
+ "${FILESDIR}/${PN}-1.51.0-support_dots_in_python-buildid.patch"
+ "${FILESDIR}/${PN}-1.48.0-no_strict_aliasing_python2.patch"
+ "${FILESDIR}/${PN}-1.48.0-disable_libboost_python3.patch"
+ "${FILESDIR}/${PN}-1.48.0-python_linking.patch"
+ "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch"
+ "${FILESDIR}/${PN}-1.55.0-context-x32.patch"
+ "${FILESDIR}/${PN}-1.56.0-build-auto_index-tool.patch"
+ "${FILESDIR}/${PN}-1.60.0-deprecated-header-ice_not.patch"
+)
+
python_bindings_needed() {
multilib_is_native_abi && use python
}
@@ -111,22 +123,12 @@ pkg_setup() {
}
src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.51.0-respect_python-buildid.patch" \
- "${FILESDIR}/${PN}-1.51.0-support_dots_in_python-buildid.patch" \
- "${FILESDIR}/${PN}-1.48.0-no_strict_aliasing_python2.patch" \
- "${FILESDIR}/${PN}-1.48.0-disable_libboost_python3.patch" \
- "${FILESDIR}/${PN}-1.48.0-python_linking.patch" \
- "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch" \
- "${FILESDIR}/${PN}-1.55.0-context-x32.patch" \
- "${FILESDIR}/${PN}-1.56.0-build-auto_index-tool.patch"
+ default
# Do not try to build missing 'wave' tool, bug #522682
# Upstream bugreport - https://svn.boost.org/trac/boost/ticket/10507
sed -i -e 's:wave/build//wave::' tools/Jamfile.v2 || die
- eapply_user
-
multilib_copy_sources
}
@@ -172,7 +174,7 @@ src_configure() {
use context || OPTIONS+=" --without-context --without-coroutine"
OPTIONS+=" pch=off"
- OPTIONS+=" --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\""
+ OPTIONS+=" --boost-build=\"${EPREFIX}\"/usr/share/boost-build --prefix=\"${ED}usr\""
OPTIONS+=" --layout=system"
OPTIONS+=" threading=$(usex threads multi single) link=$(usex static-libs shared,static shared)"
diff --git a/dev-libs/boost/files/boost-1.48.0-disable_icu_rpath.patch b/dev-libs/boost/files/boost-1.48.0-disable_icu_rpath.patch
index a902d61bba7..23a87830d10 100644
--- a/dev-libs/boost/files/boost-1.48.0-disable_icu_rpath.patch
+++ b/dev-libs/boost/files/boost-1.48.0-disable_icu_rpath.patch
@@ -1,5 +1,5 @@
---- libs/locale/build/Jamfile.v2
-+++ libs/locale/build/Jamfile.v2
+--- a/libs/locale/build/Jamfile.v2
++++ b/libs/locale/build/Jamfile.v2
@@ -58,8 +58,8 @@
if $(ICU_LINK)
diff --git a/dev-libs/boost/files/boost-1.48.0-disable_libboost_python3.patch b/dev-libs/boost/files/boost-1.48.0-disable_libboost_python3.patch
index c24a56c6bd5..d4560400d7d 100644
--- a/dev-libs/boost/files/boost-1.48.0-disable_libboost_python3.patch
+++ b/dev-libs/boost/files/boost-1.48.0-disable_libboost_python3.patch
@@ -1,5 +1,5 @@
---- libs/python/build/Jamfile.v2
-+++ libs/python/build/Jamfile.v2
+--- a/libs/python/build/Jamfile.v2
++++ b/libs/python/build/Jamfile.v2
@@ -39,23 +39,6 @@
PYTHON_ID = [ regex.replace $(python-id) "[*\\/:\"\']" "_" ] ;
}
diff --git a/dev-libs/boost/files/boost-1.48.0-no_strict_aliasing_python2.patch b/dev-libs/boost/files/boost-1.48.0-no_strict_aliasing_python2.patch
index 89f8109a411..cb26792f99c 100644
--- a/dev-libs/boost/files/boost-1.48.0-no_strict_aliasing_python2.patch
+++ b/dev-libs/boost/files/boost-1.48.0-no_strict_aliasing_python2.patch
@@ -1,5 +1,5 @@
---- libs/python/build/Jamfile.v2
-+++ libs/python/build/Jamfile.v2
+--- a/libs/python/build/Jamfile.v2
++++ b/libs/python/build/Jamfile.v2
@@ -85,6 +85,12 @@
rule lib_boost_python ( is-py3 ? )
{
diff --git a/dev-libs/boost/files/boost-1.48.0-python_linking.patch b/dev-libs/boost/files/boost-1.48.0-python_linking.patch
index e7f4e7c99f2..330cbb11e88 100644
--- a/dev-libs/boost/files/boost-1.48.0-python_linking.patch
+++ b/dev-libs/boost/files/boost-1.48.0-python_linking.patch
@@ -1,5 +1,5 @@
---- libs/python/build/Jamfile.v2
-+++ libs/python/build/Jamfile.v2
+--- a/libs/python/build/Jamfile.v2
++++ b/libs/python/build/Jamfile.v2
@@ -109,20 +109,7 @@
<link>static:<define>BOOST_PYTHON_STATIC_LIB
<define>BOOST_PYTHON_SOURCE
diff --git a/dev-libs/boost/files/boost-1.51.0-respect_python-buildid.patch b/dev-libs/boost/files/boost-1.51.0-respect_python-buildid.patch
index 327429e2c0b..17a681611b6 100644
--- a/dev-libs/boost/files/boost-1.51.0-respect_python-buildid.patch
+++ b/dev-libs/boost/files/boost-1.51.0-respect_python-buildid.patch
@@ -1,7 +1,7 @@
https://svn.boost.org/trac/boost/ticket/6286
---- boostcpp.jam
-+++ boostcpp.jam
+--- a/boostcpp.jam
++++ b/boostcpp.jam
@@ -99,13 +99,6 @@
BUILD_ID = [ regex.replace $(build-id) "[*\\/:.\"\' ]" _ ] ;
}
@@ -16,8 +16,8 @@ https://svn.boost.org/trac/boost/ticket/6286
################################################################################
#
---- libs/mpi/build/Jamfile.v2
-+++ libs/mpi/build/Jamfile.v2
+--- a/libs/mpi/build/Jamfile.v2
++++ b/libs/mpi/build/Jamfile.v2
@@ -8,6 +8,8 @@
# Authors: Douglas Gregor
# Andrew Lumsdaine
@@ -41,8 +41,8 @@ https://svn.boost.org/trac/boost/ticket/6286
rule tag ( name : type ? : property-set )
{
local result = $(name) ;
---- libs/python/build/Jamfile.v2
-+++ libs/python/build/Jamfile.v2
+--- a/libs/python/build/Jamfile.v2
++++ b/libs/python/build/Jamfile.v2
@@ -2,6 +2,8 @@
# Software License, Version 1.0. (See accompanying
# file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
diff --git a/dev-libs/boost/files/boost-1.51.0-support_dots_in_python-buildid.patch b/dev-libs/boost/files/boost-1.51.0-support_dots_in_python-buildid.patch
index c8dc6e1b7e4..a8912eb5e04 100644
--- a/dev-libs/boost/files/boost-1.51.0-support_dots_in_python-buildid.patch
+++ b/dev-libs/boost/files/boost-1.51.0-support_dots_in_python-buildid.patch
@@ -1,5 +1,5 @@
---- libs/mpi/build/Jamfile.v2
-+++ libs/mpi/build/Jamfile.v2
+--- a/libs/mpi/build/Jamfile.v2
++++ b/libs/mpi/build/Jamfile.v2
@@ -30,7 +30,7 @@
python-id = [ option.get "python-buildid" ] ;
if $(python-id)
@@ -9,8 +9,8 @@
}
rule tag ( name : type ? : property-set )
---- libs/python/build/Jamfile.v2
-+++ libs/python/build/Jamfile.v2
+--- a/libs/python/build/Jamfile.v2
++++ b/libs/python/build/Jamfile.v2
@@ -36,7 +36,7 @@
python-id = [ option.get "python-buildid" ] ;
if $(python-id)
diff --git a/dev-libs/boost/files/boost-1.56.0-build-auto_index-tool.patch b/dev-libs/boost/files/boost-1.56.0-build-auto_index-tool.patch
index 5175800e3f4..48ca5138871 100644
--- a/dev-libs/boost/files/boost-1.56.0-build-auto_index-tool.patch
+++ b/dev-libs/boost/files/boost-1.56.0-build-auto_index-tool.patch
@@ -1,8 +1,8 @@
Build auto_index tool with USE="tools"
Gentoo bug report: https://bugs.gentoo.org/show_bug.cgi?id=529066
---- tools/Jamfile.v2.orig 2014-12-24 12:57:32.290880067 +0300
-+++ tools/Jamfile.v2 2014-12-24 12:58:38.403883250 +0300
+--- a/tools/Jamfile.v2.orig 2014-12-24 12:57:32.290880067 +0300
++++ b/tools/Jamfile.v2 2014-12-24 12:58:38.403883250 +0300
@@ -20,6 +20,7 @@
use-project /boost/regression : regression/build ;
diff --git a/dev-libs/boost/files/boost-1.60.0-deprecated-header-ice_not.patch b/dev-libs/boost/files/boost-1.60.0-deprecated-header-ice_not.patch
new file mode 100644
index 00000000000..624dc648ae4
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.60.0-deprecated-header-ice_not.patch
@@ -0,0 +1,42 @@
+From: jzmaddock <john@johnmaddock.co.uk>
+Date: Tue, 21 Jul 2015 18:54:48 +0100
+Subject: [PATCH] Remove deprecated type_traits usage.
+
+---
+ include/boost/graph/adjacency_matrix.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/boost/graph/adjacency_matrix.hpp b/include/boost/graph/adjacency_matrix.hpp
+index b1078d9..ade7351 100644
+--- a/boost/graph/adjacency_matrix.hpp
++++ b/boost/graph/adjacency_matrix.hpp
+@@ -443,7 +443,7 @@ namespace boost {
+ // graph type. Instead, use directedS, which also provides the
+ // functionality required for a Bidirectional Graph (in_edges,
+ // in_degree, etc.).
+- BOOST_STATIC_ASSERT(type_traits::ice_not<(is_same<Directed, bidirectionalS>::value)>::value);
++ BOOST_STATIC_ASSERT(!(is_same<Directed, bidirectionalS>::value));
+
+ typedef typename mpl::if_<is_directed,
+ bidirectional_tag, undirected_tag>::type
+From: Vladimir Prus <vladimir.prus@gmail.com>
+Date: Mon, 7 Dec 2015 13:55:07 +0300
+Subject: [PATCH] Add missing include of <list>.
+
+Thanks to Amit Prakash Ambasta for the report.
+---
+ include/boost/graph/r_c_shortest_paths.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/boost/graph/r_c_shortest_paths.hpp b/include/boost/graph/r_c_shortest_paths.hpp
+index afa50cf..7e490fc 100644
+--- a/boost/graph/r_c_shortest_paths.hpp
++++ b/boost/graph/r_c_shortest_paths.hpp
+@@ -11,6 +11,7 @@
+ #include <map>
+ #include <queue>
+ #include <vector>
++#include <list>
+
+ #include <boost/graph/graph_traits.hpp>
+ #include <boost/graph/iteration_macros.hpp>