summaryrefslogtreecommitdiff
path: root/dev-libs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-12 21:41:18 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-12 23:27:43 +0200
commitdecac89babd088840fd738bdbece4cdd36e24cfb (patch)
tree69fb8b2538639879e6448aa189ac01695eecba8c /dev-libs
parente6ffdb6a7e3fb4a8c0e72b1d6b5ae7f6d3b7931a (diff)
downloadgentoo-decac89babd088840fd738bdbece4cdd36e24cfb.tar.gz
gentoo-decac89babd088840fd738bdbece4cdd36e24cfb.tar.xz
dev-libs/libedit: Fix building with ncurses[tinfo]
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libedit/files/libedit-20170329.3.1-tinfo.patch30
-rw-r--r--dev-libs/libedit/libedit-20170329.3.1.ebuild8
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-libs/libedit/files/libedit-20170329.3.1-tinfo.patch b/dev-libs/libedit/files/libedit-20170329.3.1-tinfo.patch
new file mode 100644
index 00000000000..e52b2559aa7
--- /dev/null
+++ b/dev-libs/libedit/files/libedit-20170329.3.1-tinfo.patch
@@ -0,0 +1,30 @@
+From 7aa660fd9d446567d3280765ba2a50a46b2a9159 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 12 Jun 2017 21:36:54 +0200
+Subject: [PATCH] configure: Support -ltinfo as split in newer ncurses
+
+The newer versions of ncurses support building terminfo routines
+as a split -ltinfo library. Account for that by adding this library
+to the search list.
+---
+ configure.ac | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9a571b2..5d714b5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -49,7 +49,9 @@ EL_MANTYPE
+ AC_CHECK_LIB(ncurses, tgetent,,
+ [AC_CHECK_LIB(curses, tgetent,,
+ [AC_CHECK_LIB(termcap, tgetent,,
+- [AC_MSG_ERROR([libncurses, libcurses, or libtermcap is required!])]
++ [AC_CHECK_LIB(tinfo, tgetent,,
++ [AC_MSG_ERROR([libncurses, libcurses, libtermcap or libtinfo is required!])]
++ )]
+ )]
+ )]
+ )
+--
+2.13.1
+
diff --git a/dev-libs/libedit/libedit-20170329.3.1.ebuild b/dev-libs/libedit/libedit-20170329.3.1.ebuild
index d2cdeab27df..bb9cfbd59ae 100644
--- a/dev-libs/libedit/libedit-20170329.3.1.ebuild
+++ b/dev-libs/libedit/libedit-20170329.3.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit multilib-minimal toolchain-funcs
+inherit autotools multilib-minimal toolchain-funcs
MY_PV=${PV/./-}
MY_P=${PN}-${MY_PV}
@@ -26,8 +26,14 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${P}-ncursesprivate.patch"
"${FILESDIR}/${P}-el_fn_sh_complete.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable static-libs static) \