summaryrefslogtreecommitdiff
path: root/dev-lisp/asdf/asdf-3.1.5.ebuild
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2015-08-27 22:05:56 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2015-08-27 22:08:59 +0200
commit3f20b7c7d501aa4e85d92a8af2156f0e2b6fcecd (patch)
treebba07ecf4e238fa81b4163d83d88312c8d726e84 /dev-lisp/asdf/asdf-3.1.5.ebuild
parentaaa265985d4635bcabf18e1d5bb0a0c9ad190389 (diff)
downloadgentoo-3f20b7c7d501aa4e85d92a8af2156f0e2b6fcecd.tar.gz
gentoo-3f20b7c7d501aa4e85d92a8af2156f0e2b6fcecd.tar.xz
dev-lisp/asdf: bump to version 3.1.5
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-lisp/asdf/asdf-3.1.5.ebuild')
-rw-r--r--dev-lisp/asdf/asdf-3.1.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-lisp/asdf/asdf-3.1.5.ebuild b/dev-lisp/asdf/asdf-3.1.5.ebuild
new file mode 100644
index 00000000000..c3a2d398ab7
--- /dev/null
+++ b/dev-lisp/asdf/asdf-3.1.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils prefix
+
+DESCRIPTION="ASDF is Another System Definition Facility for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/asdf/"
+SRC_URI="http://common-lisp.net/project/${PN}/archives/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="doc"
+
+SLOT="0/${PVR}"
+
+DEPEND="!dev-lisp/cl-${PN}
+ !dev-lisp/asdf-binary-locations
+ !dev-lisp/gentoo-init
+ !<dev-lisp/asdf-2.33-r3
+ doc? ( virtual/texi2dvi )"
+RDEPEND=""
+PDEPEND="~dev-lisp/uiop-${PV}"
+
+#S="${WORKDIR}"
+
+src_compile() {
+ make
+ use doc && make doc
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/${PN}
+ doins -r build version.lisp-expr
+ dodoc README.md TODO
+ dohtml doc/*.{html,css,ico,png}
+ if use doc; then
+ dohtml -r doc/index.html
+ insinto /usr/share/doc/${PF}
+ #doins doc/${PN}.pdf
+ fi
+
+ insinto /etc/common-lisp
+ cd "${T}"
+ cp "${FILESDIR}"/gentoo-init.lisp "${FILESDIR}"/source-registry.conf .
+ eprefixify gentoo-init.lisp source-registry.conf
+ doins gentoo-init.lisp source-registry.conf
+}