summaryrefslogtreecommitdiff
path: root/dev-lisp/gentoo-init
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lisp/gentoo-init
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lisp/gentoo-init')
-rw-r--r--dev-lisp/gentoo-init/files/gentoo-init-1.lisp11
-rw-r--r--dev-lisp/gentoo-init/files/gentoo-init.lisp7
-rw-r--r--dev-lisp/gentoo-init/files/source-registry.conf5
-rw-r--r--dev-lisp/gentoo-init/gentoo-init-0.1.ebuild24
-rw-r--r--dev-lisp/gentoo-init/gentoo-init-1.0.ebuild23
-rw-r--r--dev-lisp/gentoo-init/metadata.xml5
6 files changed, 75 insertions, 0 deletions
diff --git a/dev-lisp/gentoo-init/files/gentoo-init-1.lisp b/dev-lisp/gentoo-init/files/gentoo-init-1.lisp
new file mode 100644
index 00000000000..263aedd10c2
--- /dev/null
+++ b/dev-lisp/gentoo-init/files/gentoo-init-1.lisp
@@ -0,0 +1,11 @@
+(in-package #:cl-user)
+
+(let ((*compile-print* nil)
+ (*compile-verbose* nil)
+ #+cmu (ext:*gc-verbose* nil))
+ (handler-bind ((warning #'muffle-warning))
+ (load #p"/usr/share/common-lisp/source/asdf/asdf.lisp"
+ :print nil :verbose nil)
+ #+ecl
+ (load #p"/usr/share/common-lisp/source/asdf/asdf-ecl.lisp"
+ :print nil :verbose nil)))
diff --git a/dev-lisp/gentoo-init/files/gentoo-init.lisp b/dev-lisp/gentoo-init/files/gentoo-init.lisp
new file mode 100644
index 00000000000..e09dcb0ae43
--- /dev/null
+++ b/dev-lisp/gentoo-init/files/gentoo-init.lisp
@@ -0,0 +1,7 @@
+(in-package #:cl-user)
+#+(or sbcl ecl) (require :asdf)
+#-(or sbcl ecl) (load #p"/usr/share/common-lisp/source/asdf/asdf.lisp")
+(push #p"/usr/share/common-lisp/systems/" asdf:*central-registry*)
+(asdf:oos 'asdf:load-op :asdf-binary-locations)
+(setf asdf:*centralize-lisp-binaries* t)
+(setf asdf:*source-to-target-mappings* '((#p"/usr/lib/sbcl/" nil) (#p"/usr/lib64/sbcl/" nil)))
diff --git a/dev-lisp/gentoo-init/files/source-registry.conf b/dev-lisp/gentoo-init/files/source-registry.conf
new file mode 100644
index 00000000000..45e1fdfc5aa
--- /dev/null
+++ b/dev-lisp/gentoo-init/files/source-registry.conf
@@ -0,0 +1,5 @@
+;; -*- Mode: Lisp; -*-
+
+(:source-registry
+ (:directory "/usr/share/common-lisp/systems")
+ :inherit-configuration)
diff --git a/dev-lisp/gentoo-init/gentoo-init-0.1.ebuild b/dev-lisp/gentoo-init/gentoo-init-0.1.ebuild
new file mode 100644
index 00000000000..3513f2199d6
--- /dev/null
+++ b/dev-lisp/gentoo-init/gentoo-init-0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="Simple ASDF-BINARY-LOCATIONS configuration for Gentoo Common Lisp ports"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/common-lisp/guide.xml"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+S=${WORKDIR}
+
+DEPEND="dev-lisp/asdf-binary-locations"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /etc
+ doins "${FILESDIR}"/gentoo-init.lisp
+}
diff --git a/dev-lisp/gentoo-init/gentoo-init-1.0.ebuild b/dev-lisp/gentoo-init/gentoo-init-1.0.ebuild
new file mode 100644
index 00000000000..af00628c15d
--- /dev/null
+++ b/dev-lisp/gentoo-init/gentoo-init-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Simple ASDF2 configuration for Gentoo Common Lisp ports"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/common-lisp/guide.xml"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-lisp/asdf-2.0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /etc/common-lisp
+ newins "${FILESDIR}"/gentoo-init-1.lisp gentoo-init.lisp
+ doins "${FILESDIR}"/source-registry.conf
+}
diff --git a/dev-lisp/gentoo-init/metadata.xml b/dev-lisp/gentoo-init/metadata.xml
new file mode 100644
index 00000000000..f418045b09c
--- /dev/null
+++ b/dev-lisp/gentoo-init/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>