summaryrefslogtreecommitdiff
path: root/dev-lua/lua_cliargs
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2016-07-08 10:22:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2016-07-12 13:49:17 -0500
commitebe78fa1faed4ef8dd9926dae19cc22a60b32437 (patch)
tree90f6f4b6e799aa8e1389f887d0d47c706f817906 /dev-lua/lua_cliargs
parent6df367e930f5fad3b29a62f30810a79b1acf1cc8 (diff)
downloadgentoo-ebe78fa1faed4ef8dd9926dae19cc22a60b32437.tar.gz
gentoo-ebe78fa1faed4ef8dd9926dae19cc22a60b32437.tar.xz
dev-lua/lua_cliargs: 3.0_p1 version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lua/lua_cliargs')
-rw-r--r--dev-lua/lua_cliargs/Manifest1
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-lua/lua_cliargs/Manifest b/dev-lua/lua_cliargs/Manifest
index 52f1554f4b1..5708639d392 100644
--- a/dev-lua/lua_cliargs/Manifest
+++ b/dev-lua/lua_cliargs/Manifest
@@ -1 +1,2 @@
DIST lua_cliargs-2.5_p5.tar.gz 19513 SHA256 7b410dc3665b9bde5d954bfa73fb8254bfd5b4e72b20924f59006ce2f080baf4 SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746 WHIRLPOOL 07991c547513cc42d5596424651b4a119c30c5ff2dd7a1cabcd125a3198ceebf9f9d466f5110a684af2497cb48afff009aed922719c3115a34823481d194c53b
+DIST lua_cliargs-3.0_p1.tar.gz 29904 SHA256 35cbd5daff3411bdada1cd6f0cd5dcd61626da90f63f26483a0b9768d60dccad SHA512 2bdcd3c790a82351df598cb3d289de980fe771222ebd9715036678eecdbe51b7563d24629afa4d286b900d722bf844004d12f2330744a1e644d9286ac44b4dbe WHIRLPOOL 31b672caffa2dca31c92001c2ce3c482dd6411732547fbe5bdd27396868a8116d2b48e749ced352963d21adf83715473aca8796df13d12b09f99cc2833fda288
diff --git a/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
new file mode 100644
index 00000000000..4a4b9043059
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-3.0_p1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="3.0-1"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r src/cliargs.lua src/cliargs
+ dodoc README.md
+ dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}