summaryrefslogtreecommitdiff
path: root/dev-lua/luaevent
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/luaevent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/luaevent')
-rw-r--r--dev-lua/luaevent/Manifest1
-rw-r--r--dev-lua/luaevent/luaevent-0.4.3.ebuild40
-rw-r--r--dev-lua/luaevent/metadata.xml13
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-lua/luaevent/Manifest b/dev-lua/luaevent/Manifest
new file mode 100644
index 00000000000..051dbf5282d
--- /dev/null
+++ b/dev-lua/luaevent/Manifest
@@ -0,0 +1 @@
+DIST luaevent-0.4.3.tar.gz 29861 SHA256 9a3ea7671caa95af2763a7125818991b3742168db75b3025d04af5241349d9c5 SHA512 5f02c9d40e59589a2b932b49d27230ca6650174feeda2cf412769c33af056c9df52d38fdd5fc12f0f6318b788e29a2deef54f11beb4becc48818edd27185f161 WHIRLPOOL 3b9e0d7dfd0f5d593957d9f34d807ebc3ceef811493efce56732ffb3c436ab21ca835e913f101eb15aa93fe98d5f12ec70538db3ae466bc8579169024ed8ea12
diff --git a/dev-lua/luaevent/luaevent-0.4.3.ebuild b/dev-lua/luaevent/luaevent-0.4.3.ebuild
new file mode 100644
index 00000000000..8fce922ddf9
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="libevent bindings for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ >=dev-libs/libevent-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i "s:^CFLAGS =:CFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LDFLAGS =:LDFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "/^LDFLAGS/a CC = $(tc-getCC)" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LUA_INC_DIR ?=.*:LUA_INC_DIR ?= $(pkg-config --variable INSTALL_INC lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_LUA ?=.*:INSTALL_DIR_LUA ?= $(pkg-config --variable INSTALL_LMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_BIN ?=.*:INSTALL_DIR_BIN ?= $(pkg-config --variable INSTALL_CMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}
diff --git a/dev-lua/luaevent/metadata.xml b/dev-lua/luaevent/metadata.xml
new file mode 100644
index 00000000000..d904e9c8164
--- /dev/null
+++ b/dev-lua/luaevent/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">harningt/luaevent</remote-id>
+ </upstream>
+</pkgmetadata>