summaryrefslogtreecommitdiff
path: root/dev-lua/luvit/luvit-0.8.2.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/luvit/luvit-0.8.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/luvit/luvit-0.8.2.ebuild')
-rw-r--r--dev-lua/luvit/luvit-0.8.2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-lua/luvit/luvit-0.8.2.ebuild b/dev-lua/luvit/luvit-0.8.2.ebuild
new file mode 100644
index 00000000000..b5c57b0cd78
--- /dev/null
+++ b/dev-lua/luvit/luvit-0.8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+# TODO: FHS https://github.com/luvit/luvit/issues/379
+
+DESCRIPTION="Takes node.js' architecture and dependencies and fits it in the Lua language"
+HOMEPAGE="http://luvit.io/"
+SRC_URI="http://luvit.io/dist/latest/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bundled-libs examples"
+# luvit Apache-2.0
+# luajit MIT
+# yajl BSD
+LICENSE="Apache-2.0 bundled-libs? ( BSD MIT )"
+
+# fails in portage environment
+# succeeds if run manually
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/openssl:0
+ sys-libs/zlib
+ !bundled-libs? (
+ dev-lang/luajit:2[lua52compat]
+ >=dev-libs/yajl-2.0.2
+ net-libs/http-parser
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -r deps/{openssl,zlib} || die
+ epatch "${FILESDIR}"/${PN}-0.7.0-unbundle-http-parser.patch
+ if use bundled-libs ; then
+ sed -i \
+ -e "s/-Werror//" \
+ -e "s/-O3//" \
+ deps/http-parser/Makefile || die "fixing flags failed!"
+ else
+ rm -r deps/{luajit,yajl,http-parser} || die
+ # TODO: no version detection for http-parser yet
+ MY_YAJL_VERSION=$($(tc-getPKG_CONFIG) --modversion yajl)
+ MY_LUAJIT_VERSION=$($(tc-getPKG_CONFIG) --modversion luajit)
+ sed -i \
+ -e "s:^YAJL_VERSION=.*:YAJL_VERSION=${MY_YAJL_VERSION}:" \
+ -e "s:^LUAJIT_VERSION=.*:LUAJIT_VERSION=${MY_LUAJIT_VERSION}:" \
+ Makefile || die "setting yajl version failed"
+ fi
+
+}
+
+src_configure() {
+ # skip retarded gyp build system
+ :
+}
+
+src_compile() {
+ tc-export CC AR
+
+ emake -C deps/cares
+
+ myemakeargs=(
+ DEBUG=0
+ WERROR=0
+ USE_SYSTEM_SSL=1
+ # bundled luajit is compiled with special flags
+ USE_SYSTEM_LUAJIT=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_YAJL=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_HTTPPARSER=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_ZLIB=1
+ PREFIX=/usr
+ LIBDIR="${D%/}"/usr/$(get_libdir)/${PN}
+ DESTDIR="${D}"
+ )
+
+ emake "${myemakeargs[@]}" all
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install
+ dodoc TODO ChangeLog README.markdown errors.markdown
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}