summaryrefslogtreecommitdiff
path: root/dev-ml/async_kernel
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/async_kernel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/async_kernel')
-rw-r--r--dev-ml/async_kernel/Manifest3
-rw-r--r--dev-ml/async_kernel/async_kernel-112.17.00.ebuild33
-rw-r--r--dev-ml/async_kernel/async_kernel-112.24.00.ebuild33
-rw-r--r--dev-ml/async_kernel/async_kernel-112.35.00.ebuild33
-rw-r--r--dev-ml/async_kernel/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-ml/async_kernel/Manifest b/dev-ml/async_kernel/Manifest
new file mode 100644
index 00000000000..8c9a811432b
--- /dev/null
+++ b/dev-ml/async_kernel/Manifest
@@ -0,0 +1,3 @@
+DIST async_kernel-112.17.00.tar.gz 133837 SHA256 eaa99169345096e111a69beb229bdb1b0bc04c72db50837a1630a5852afe1464 SHA512 268a742fad491597635a53b4208730350f07e2b65cd8a6adaa17e9d862b3eefaed4a3badcb4c03cae2462882173d848d472dd1bdd9c0b041fe55814a28098b03 WHIRLPOOL fecc39757b0402cca04fb007ea9a8f6004cc350770a72f17b1ed2ab42a2ecd30fe38217c92924bef591958fd516c1896191a8c393b59f09844cc28536d8769bd
+DIST async_kernel-112.24.tar.gz 135816 SHA256 95caf4249b55c5a6b38da56e314845e9ea9a0876eedd4cf0ddcb6c8dd660c6a0 SHA512 cf3bfc29147f37c03d5b9af55f6c71256cdc54b26c186303dd95675c541733b54fff5a816f57c682a9ec4f1e1d107ba8bbc92f7202a64de768eeb03c76eb4b3b WHIRLPOOL f452328b17a68e31f69cbaf1af6492788e98cffc3ccff79c81b78983694d197011d4d6d674b98f2b248bbcf6171c787cfeb5bfecf68b4ebd301ebf437e584a4b
+DIST async_kernel-112.35.00.tar.gz 142997 SHA256 6bb859c7ca8b6d6766d4cb4ff40ecc91ecf70ae4224c95a455e5edffd244f448 SHA512 f4b726bb801f2e698c9184a109bbc3b5921adfe2c44d9d219de0049b4623985ec9e5bb3fe8928a9d6c34ca30ff5b0c13bb4681f271c16305e82c476af9c99919 WHIRLPOOL ae06b260f13755d97eca5681fc3a3d86af1660d552ac349c3373ac630583f1e3120c77884cf040b237e566b65dac2b6df1562095d1d6891b2db7f86453e3f42d
diff --git a/dev-ml/async_kernel/async_kernel-112.17.00.ebuild b/dev-ml/async_kernel/async_kernel-112.17.00.ebuild
new file mode 100644
index 00000000000..6fec34ca2fc
--- /dev/null
+++ b/dev-ml/async_kernel/async_kernel-112.17.00.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (core)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/core-109.35.00:=
+ >=dev-ml/herelib-109.35.00:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_kernel/async_kernel-112.24.00.ebuild b/dev-ml/async_kernel/async_kernel-112.24.00.ebuild
new file mode 100644
index 00000000000..ef8a8607f7e
--- /dev/null
+++ b/dev-ml/async_kernel/async_kernel-112.24.00.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (core)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/core-109.35.00:=
+ >=dev-ml/herelib-109.35.00:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_kernel/async_kernel-112.35.00.ebuild b/dev-ml/async_kernel/async_kernel-112.35.00.ebuild
new file mode 100644
index 00000000000..6fec34ca2fc
--- /dev/null
+++ b/dev-ml/async_kernel/async_kernel-112.35.00.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (core)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/core-109.35.00:=
+ >=dev-ml/herelib-109.35.00:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-ml/async_kernel/metadata.xml b/dev-ml/async_kernel/metadata.xml
new file mode 100644
index 00000000000..2193d772e35
--- /dev/null
+++ b/dev-ml/async_kernel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>