summaryrefslogtreecommitdiff
path: root/dev-ml/bin-prot
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 11:57:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 12:02:53 +0100
commit0ad0986dcd741152545ea92bf8170d885da23d7d (patch)
tree9ce64980a46ef4689b9a2970a98e9d90fc5ad4e4 /dev-ml/bin-prot
parent5d162302b1dedb4e08fd0ecd639d0b1d8e37cc09 (diff)
downloadgentoo-0ad0986dcd741152545ea92bf8170d885da23d7d.tar.gz
gentoo-0ad0986dcd741152545ea92bf8170d885da23d7d.tar.xz
dev-ml/bin-prot: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/Manifest1
-rw-r--r--dev-ml/bin-prot/bin-prot-113.33.00.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/Manifest b/dev-ml/bin-prot/Manifest
index c1ae3688b33..3b33bc13811 100644
--- a/dev-ml/bin-prot/Manifest
+++ b/dev-ml/bin-prot/Manifest
@@ -1 +1,2 @@
DIST bin_prot-113.24.00.tar.gz 278825 SHA256 d6124d8a3033680076b5a6787b9e77af6840503406c4de375b19c754579fd97f SHA512 1139dc3d3456f85c7b6514fc513c5e10a551c2a4a0e245793c8e731204edea5d9a5b5a326eed38b8169a1b9f3c00e761f8a3070c62827c53fe1d894f9d6aad52 WHIRLPOOL 375dceee9cea0ae22dd30d414f97c9282ab160267bfe53c3b848e0876a054c0be64cde3a7bf6b34d6df7f6a3cbc16b999368f889093b5cf7e0c11cad4af1b93c
+DIST bin_prot-113.33.00.tar.gz 280362 SHA256 51cac973cce539e6ce3dfbafbe9dc631283d43b121e546c541b0578ca3213f5c SHA512 58772b0f56f6d4a09ded3a77d9f0b2e674b27ef387fb732bf682cd58cabc0c72d1dca0238d71b69f9576cc3105b41464a543154ea20854b20e8ed31e77599c09 WHIRLPOOL e652fc32f9de7ac0ecfdb3190eb54220ada631807907c17138da69f5a80d1d8ac4da1ff6b0bea8424e148a164e36d494dee3f64511572ef130089ad71db561aa
diff --git a/dev-ml/bin-prot/bin-prot-113.33.00.ebuild b/dev-ml/bin-prot/bin-prot-113.33.00.ebuild
new file mode 100644
index 00000000000..e10bfb91fe0
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-113.33.00.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-109.28.00:="
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN/-/_}.install || die
+ dodoc CHANGES.md README.md
+}