summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-07 14:19:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-07 14:19:13 +0100
commit0113fd6c739fa174f5fb802fc442b77ec6583565 (patch)
tree12b7092e71aae64e0626667861cfdc94f3ec7ab2 /dev-ml/camlzip
parent26a0c08095658048936bb96b876f93a03fe55783 (diff)
downloadgentoo-0113fd6c739fa174f5fb802fc442b77ec6583565.tar.gz
gentoo-0113fd6c739fa174f5fb802fc442b77ec6583565.tar.xz
dev-ml/camlzip: Bump to 1.07
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/camlzip')
-rw-r--r--dev-ml/camlzip/Manifest1
-rw-r--r--dev-ml/camlzip/camlzip-1.07.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 83111738a87..6839239cfd6 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1 +1,2 @@
DIST camlzip-1.06.tar.gz 26499 SHA256 c83877f9972943e6f2e147cf9715a785da2fc8531e7bed3ab4787043b8f4cf54 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd WHIRLPOOL a83ad24836d64adc00324f44ce5f3877c8d912afe14dcb0ad5b8788a52dfe777b2b582e240e74ed24bda950ca0202505792e62f9c205f0a5f39c33918e70217a
+DIST camlzip-1.07.tar.gz 26652 SHA256 2f4df4df258b8bca89176a5c4200a6920eccb3134f3df70d61a67e16fd1fbfdd SHA512 b92e9db002b9b398fd132c6ecd8098fac4cc7ddb3f770cc412990dcdf4bd62ba358c762d31fb0b5cd6b32f20d3bf4b3410ca6e86c511a438b92ece940f9831bd WHIRLPOOL 94e6a8cb2f70104f864b2dc4e52efd0c93082315b2dc32a7d32f4d7f5398811af1ac992021310a6ad9a4850347e4cc73acb240ac2551d33d45a7eb4f28bdd30e
diff --git a/dev-ml/camlzip/camlzip-1.07.ebuild b/dev-ml/camlzip/camlzip-1.07.ebuild
new file mode 100644
index 00000000000..447007fb2ec
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.07.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils versionator
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(delete_all_version_separators ${PV}).tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(delete_all_version_separators ${PV})"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}