summaryrefslogtreecommitdiff
path: root/dev-ml/cppo
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-09 10:28:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-09 10:28:03 +0200
commit5b3a9114a4b4fb216da3719f494f6310bbcba955 (patch)
treeafbc798c4e69a53b50437c53dde1a5d6f26ee608 /dev-ml/cppo
parent2cb38bc42a2d5cea1a1fa428916aa0c0641d145f (diff)
downloadgentoo-5b3a9114a4b4fb216da3719f494f6310bbcba955.tar.gz
gentoo-5b3a9114a4b4fb216da3719f494f6310bbcba955.tar.xz
dev-ml/cppo: Fix build with USE=-ocamlopt. Bug #624286
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/cppo')
-rw-r--r--dev-ml/cppo/cppo-1.5.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-ml/cppo/cppo-1.5.0.ebuild b/dev-ml/cppo/cppo-1.5.0.ebuild
index c9d5a1d7375..edc62efc16d 100644
--- a/dev-ml/cppo/cppo-1.5.0.ebuild
+++ b/dev-ml/cppo/cppo-1.5.0.ebuild
@@ -22,7 +22,7 @@ DEPEND="${RDEPEND}"
src_compile() {
use ocamlopt || sed -e 's/ocamlbuild_cppo.cmx/ocamlbuild_cppo.cmo/' -i Makefile
- emake BEST="$(usex ocamlopt '.native' '.byte')"
+ emake BEST="$(usex ocamlopt '.native' '.byte')" $(usex ocamlopt opt all) ocamlbuild
}
src_install() {