summaryrefslogtreecommitdiff
path: root/dev-ml/deriving-ocsigen
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/deriving-ocsigen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/deriving-ocsigen')
-rw-r--r--dev-ml/deriving-ocsigen/Manifest1
-rw-r--r--dev-ml/deriving-ocsigen/deriving-ocsigen-0.3c.ebuild51
-rw-r--r--dev-ml/deriving-ocsigen/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-ml/deriving-ocsigen/Manifest b/dev-ml/deriving-ocsigen/Manifest
new file mode 100644
index 00000000000..d02364ba704
--- /dev/null
+++ b/dev-ml/deriving-ocsigen/Manifest
@@ -0,0 +1 @@
+DIST deriving-ocsigen-0.3c.tar.gz 61242 SHA256 eb6e7e647b6f2effcc65c9b32076fbc12e366e16035447a762a93e5e1cba94c7 SHA512 121225b2a143676ec7e49e2f8eb22b674280e74276192d2ffb9b3e063cb47029421bffab87f838ad74bcfa08af27a53a5d745f2dc2398eae3e0e9c02849c818a WHIRLPOOL a9686b3b064a1bdacae2415248c2b7a825738ab7889d6fd56ffa575694ddb151d928b07621aca1d1be9c4fb624647fb5c0be2debdeea5d3fdae879a555b9b980
diff --git a/dev-ml/deriving-ocsigen/deriving-ocsigen-0.3c.ebuild b/dev-ml/deriving-ocsigen/deriving-ocsigen-0.3c.ebuild
new file mode 100644
index 00000000000..28677f2be0d
--- /dev/null
+++ b/dev-ml/deriving-ocsigen/deriving-ocsigen-0.3c.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A deriving library for Ocsigen"
+HOMEPAGE="http://ocsigen.org"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt type-conv"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ type-conv? ( >=dev-ml/type-conv-108:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ find . -type f -exec sed -i 's/type-conv/type_conv/g' {} +
+}
+
+src_configure() {
+ use type-conv || echo "TYPECONV :=" >> Makefile.config
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake
+ else
+ emake byte
+ fi
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake install
+ else
+ emake install-byte
+ fi
+ dodoc CHANGES README
+}
diff --git a/dev-ml/deriving-ocsigen/metadata.xml b/dev-ml/deriving-ocsigen/metadata.xml
new file mode 100644
index 00000000000..009b874f943
--- /dev/null
+++ b/dev-ml/deriving-ocsigen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+<use>
+ <flag name='type-conv'>Enable type-conv for the syntax extention.</flag>
+</use>
+</pkgmetadata>