summaryrefslogtreecommitdiff
path: root/dev-ml/extlib/extlib-1.6.1-r1.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-29 21:15:11 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-29 21:17:05 +0200
commit6e9d123f36abfc590c770900a3d450e7a24bb171 (patch)
tree095577dc712fd1c5ae9d9f7a9f9c8765ae73b402 /dev-ml/extlib/extlib-1.6.1-r1.ebuild
parent27072fc59258d271b3781569c29e8313ab12838f (diff)
downloadgentoo-6e9d123f36abfc590c770900a3d450e7a24bb171.tar.gz
gentoo-6e9d123f36abfc590c770900a3d450e7a24bb171.tar.xz
dev-ml/extlib: Drop non-camlp4 support, #586910
Diffstat (limited to 'dev-ml/extlib/extlib-1.6.1-r1.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.6.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.6.1-r1.ebuild b/dev-ml/extlib/extlib-1.6.1-r1.ebuild
new file mode 100644
index 00000000000..b7c0f30b3de
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://code.google.com/p/ocaml-extlib/"
+SRC_URI="https://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/camlp4:=
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}