summaryrefslogtreecommitdiff
path: root/dev-ml/flow_parser
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-29 08:46:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-29 22:28:00 +0200
commitab23f3ebd76a9171cb7cdf820536151ea319ac47 (patch)
tree2d7f45a189f721a50d75afaae41d35926adc2669 /dev-ml/flow_parser
parentb1a7707f549c11e594465c8740010ff71ca65ea5 (diff)
downloadgentoo-ab23f3ebd76a9171cb7cdf820536151ea319ac47.tar.gz
gentoo-ab23f3ebd76a9171cb7cdf820536151ea319ac47.tar.xz
dev-ml/flow_parser: bump to 0.49.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/flow_parser')
-rw-r--r--dev-ml/flow_parser/Manifest1
-rw-r--r--dev-ml/flow_parser/flow_parser-0.49.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/flow_parser/Manifest b/dev-ml/flow_parser/Manifest
index 4dfae4bcad4..5f6e4e5be7b 100644
--- a/dev-ml/flow_parser/Manifest
+++ b/dev-ml/flow_parser/Manifest
@@ -1 +1,2 @@
DIST flow-0.48.0.tar.gz 2612834 SHA256 8772896075dc4028e62720fe18a6608f278f471931b2a8fff280d0efc0fd4f29 SHA512 cad7c38cdb629113955c93480eb7e12a33e5048536d4ae43416998c75913bdb63df5047774e7ac6225ba8f9d56aa232949fcdad7dae26316f5724b4af5de762d WHIRLPOOL 817482d0d17758a4eb61412a4b27e24f11e19d2bb431c2445120a4a62bb8d8b29b31f686632d5453de8073b9929acab2b7fc34286391c002b5390a275361c82f
+DIST flow-0.49.1.tar.gz 2630020 SHA256 d72a3470e7e0879d37f242aa0ec561ed0e60ff9fba676156392e46fd5e27a180 SHA512 416773b9c2c9d4f50d4a86da5b00038b732bad8a4434c4aeed1a5e2d2cfe24ae190b1ba0912287ce6d4435a45502daa73ff7fc3f9cb0676b204d3ca2f98e66ba WHIRLPOOL b5a55b34507c9656e93541ada65d9d998d36b4d0ac5ae48501c95c97ffad6b1e2780c78764bdfa156ed9130a43f9e76572dba0b0395b6ff95df90b0ed0a0ae21
diff --git a/dev-ml/flow_parser/flow_parser-0.49.1.ebuild b/dev-ml/flow_parser/flow_parser-0.49.1.ebuild
new file mode 100644
index 00000000000..a36131a0f03
--- /dev/null
+++ b/dev-ml/flow_parser/flow_parser-0.49.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="JavaScript parser written in OCaml"
+HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
+SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sedlex:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+S="${WORKDIR}/flow-${PV}/src/parser"
+
+src_compile() {
+ emake build-parser
+}
+
+src_test() {
+ emake test-ocaml
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+}