summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-15 13:22:44 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-15 14:35:35 +0200
commitd75b1a18d1de933041ac0f74d18f3334343cdba1 (patch)
treea8f70bd4abcbb685e3c89274f7ede60b2c6f5ec8 /dev-ml/llvm-ocaml
parentb4836e88a5c9fefdff18941eb028a4ba0c80d45e (diff)
downloadgentoo-d75b1a18d1de933041ac0f74d18f3334343cdba1.tar.gz
gentoo-d75b1a18d1de933041ac0f74d18f3334343cdba1.tar.xz
dev-ml/llvm-ocaml: Include all experimental targets in -9999
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
index b377e8cd12a..b4f26a2e7dd 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
@@ -17,8 +17,10 @@ EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
# Keep in sync with sys-devel/llvm
+ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV WebAssembly )
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
+ NVPTX PowerPC Sparc SystemZ X86 XCore
+ "${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
@@ -72,7 +74,10 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_OCAML_OUT_OF_TREE=ON
- -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ # cheap hack: LLVM combines both anyway, and the only difference
+ # is that the former list is explicitly verified at cmake time
+ -DLLVM_TARGETS_TO_BUILD=""
+ -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_BUILD_TESTS=$(usex test)
# disable various irrelevant deps and settings