summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-mysql
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 12:41:04 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 12:41:04 +0100
commit6d3e0504ab97a027080d851458498db736fff8e7 (patch)
tree56e263f6bdc63759be0faa40f212a4a9aa694ca9 /dev-ml/ocaml-mysql
parent7792997929a7a75537d3a294fdf97a29f1861b12 (diff)
downloadgentoo-6d3e0504ab97a027080d851458498db736fff8e7.tar.gz
gentoo-6d3e0504ab97a027080d851458498db736fff8e7.tar.xz
dev-ml/ocaml-mysql: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/Manifest2
-rw-r--r--dev-ml/ocaml-mysql/files/oc43.patch37
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild39
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild43
4 files changed, 0 insertions, 121 deletions
diff --git a/dev-ml/ocaml-mysql/Manifest b/dev-ml/ocaml-mysql/Manifest
index 5589e837c9e..34061a4b0fc 100644
--- a/dev-ml/ocaml-mysql/Manifest
+++ b/dev-ml/ocaml-mysql/Manifest
@@ -1,3 +1 @@
-DIST ocaml-mysql-1.1.1.tar.gz 119676 SHA256 f896fa101a05d81b85af8122fe1c2809008a5e5fdca00f9ceeb7eec356369e3a SHA512 a57e69bbde928aa15e4200cf08fe4504450ae95afbec96fab03412708986a628463acaadb1b66c8955baa0c8c8c5260ebeb2e961b907a056749c6546e006988f WHIRLPOOL dbc1ef77b1cb38002a852665561ff69234117d2c241a3d75769e7217b0e7fe40b7474be3da2781a9d28729c46274dab3d79a201b53320b4ce0140b2ea1492d5a
-DIST ocaml-mysql-1.2.0.tar.gz 99236 SHA256 6eb2c218c9a16b3c92ba4e8ecb91dbf34ef221623a0f88c29eb84511dd0b9dff SHA512 d8a45e4df63648b8481faee40e614840044b4d4c41d704cead2bf66e794140908df23d1f960bac39a366dad8cba39797225f25ea598d46801f9a9f48c54eaae3 WHIRLPOOL cb4e9f695ac5ae1e7edc0f6b25f3f5c74597d1d2c598f2ab721a9f6868e036b9d3c247225d406eed6b35b8bc31c02f0a35292925f1a8208c99dc3cc5256b2bbb
DIST ocaml-mysql-1.2.1.tar.gz 99250 SHA256 827a43e1341721eba5afe3acdec3d38bac87ff092918f529b0fc8c7df012ab1a SHA512 bf9b4a1bfcc1a8d356a2d74ea9d8de8dd201973b9dc89c06349e814c2368871f5f6ccc2eca25b33fa5fabf4b6d19a5b4b436a1e055b90468f16f575257121e64 WHIRLPOOL dbbb1a7acb0914c9ed829a12ddd58d0fee1e88d046bb624106b5e72abf932090d2da42cda9948a31183f1e01f8f8e10335520349fd2669a576622a4f1edff79a
diff --git a/dev-ml/ocaml-mysql/files/oc43.patch b/dev-ml/ocaml-mysql/files/oc43.patch
deleted file mode 100644
index 5782c343cda..00000000000
--- a/dev-ml/ocaml-mysql/files/oc43.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: ocaml-mysql-1.2.0/mysql_stubs.c
-===================================================================
---- ocaml-mysql-1.2.0.orig/mysql_stubs.c
-+++ ocaml-mysql-1.2.0/mysql_stubs.c
-@@ -508,14 +508,14 @@ db_fetch (value result)
-
- EXTERNAL value
- db_to_row(value result, value offset) {
-- int64 off = Int64_val(offset);
-+ int64_t off = Int64_val(offset);
- MYSQL_RES *res;
-
- res = RESval(result);
- if (!res)
- mysqlfailwith("Mysql.to_row: result did not return fetchable data");
-
-- if (off < 0 || off > (int64)mysql_num_rows(res)-1)
-+ if (off < 0 || off > (int64_t)mysql_num_rows(res)-1)
- invalid_argument("Mysql.to_row: offset out of range");
-
- mysql_data_seek(res, off);
-@@ -640,13 +640,13 @@ db_size(value result)
- {
- CAMLparam1(result);
- MYSQL_RES *res;
-- int64 size;
-+ int64_t size;
-
- res = RESval(result);
- if (!res)
- size = 0;
- else
-- size = (int64)(mysql_num_rows(res));
-+ size = (int64_t)(mysql_num_rows(res));
-
- CAMLreturn(copy_int64(size));
- }
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
deleted file mode 100644
index b681c4b7ab6..00000000000
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-IUSE="+ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to mysql databases"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/870/${P}.tar.gz"
-HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
-
-DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- sys-libs/zlib
- >=virtual/mysql-4.0"
-
-RDEPEND="$DEPEND"
-
-SLOT="0/${PV}"
-LICENSE="LGPL-2"
-KEYWORDS="~amd64 ppc x86"
-
-src_compile()
-{
- emake all
- if use ocamlopt; then
- emake opt
- fi
-}
-
-src_install()
-{
- findlib_src_preinst
- emake install
-
- dodoc CHANGES README VERSION || die
-}
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild
deleted file mode 100644
index af4aeb1b864..00000000000
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-IUSE="+ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to mysql databases"
-SRC_URI="https://forge.ocamlcore.org/frs/download.php/1500/${P}.tar.gz"
-HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
-
-DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- sys-libs/zlib
- >=virtual/mysql-4.0"
-
-RDEPEND="$DEPEND"
-
-SLOT="0/${PV}"
-LICENSE="LGPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_compile()
-{
- emake all
- if use ocamlopt; then
- emake opt
- fi
-}
-
-src_install()
-{
- findlib_src_preinst
- emake install
-
- dodoc CHANGES README VERSION || die
-}