summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-pcap
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-10-16 14:29:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-17 19:21:08 +0200
commit80692cdd3f404bf61be06c0ca3b64e9c7fd17b51 (patch)
tree3bb89ff68a5bcd79829ae40131e0dce8bc406c82 /dev-ml/ocaml-pcap
parent2719e0e970ef1969f83e5dd81a262bd13a8795ef (diff)
downloadgentoo-80692cdd3f404bf61be06c0ca3b64e9c7fd17b51.tar.gz
gentoo-80692cdd3f404bf61be06c0ca3b64e9c7fd17b51.tar.xz
dev-ml/ocaml-pcap: new ebuild
- needed as a transitive dependency of Libre S3 1.1 (net-misc/libres3) - explicit support for MirageOS is not enabled
Diffstat (limited to 'dev-ml/ocaml-pcap')
-rw-r--r--dev-ml/ocaml-pcap/Manifest1
-rw-r--r--dev-ml/ocaml-pcap/metadata.xml9
-rw-r--r--dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild34
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-pcap/Manifest b/dev-ml/ocaml-pcap/Manifest
new file mode 100644
index 00000000000..b066fa9184a
--- /dev/null
+++ b/dev-ml/ocaml-pcap/Manifest
@@ -0,0 +1 @@
+DIST ocaml-pcap-0.3.3.tar.gz 45752 SHA256 9419a1701310b2d9130be3d305a6e2cb0cb2c8da0348a6c9fc49bbe2a5d6ae76 SHA512 732f895c08b114aef34ea3b776c69d67696e290f2a2952405b75097ce0253fcc8a754dd223ac4ce98b134786f46c328cc2510f7313c4c8c4042d242a1a4de8a1 WHIRLPOOL 0a39017e791e1031b0f1500e3f9eb055db66dda3c35c0ba027f579f4a3066c824bb066733cce9ab07e37e679694bc909ef0b3c812b71570a1563e5a28121b00d
diff --git a/dev-ml/ocaml-pcap/metadata.xml b/dev-ml/ocaml-pcap/metadata.xml
new file mode 100644
index 00000000000..a33970c685b
--- /dev/null
+++ b/dev-ml/ocaml-pcap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tomboy64@sina.cn</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild b/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild
new file mode 100644
index 00000000000..8d7f9d77493
--- /dev/null
+++ b/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Read and write pcap-formatted network packet traces."
+HOMEPAGE="https://github.com/mirage/ocaml-pcap https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Blockers taken from opam file and only relevant
+# if MirageOS should enter portage.
+RDEPEND="
+ dev-ml/ocaml-ipaddr:=
+ !dev-ml/mirage-net-socket
+ !<dev-ml/mirage-0.9.2
+ >=dev-ml/ocaml-cstruct-0.6.0:=[camlp4(-)]
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ >=dev-ml/lwt-2.4.0 )
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES MAINTAINERS README.md )