summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlmod
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocamlmod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocamlmod')
-rw-r--r--dev-ml/ocamlmod/Manifest2
-rw-r--r--dev-ml/ocamlmod/metadata.xml5
-rw-r--r--dev-ml/ocamlmod/ocamlmod-0.0.3.ebuild24
-rw-r--r--dev-ml/ocamlmod/ocamlmod-0.0.7.ebuild24
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/ocamlmod/Manifest b/dev-ml/ocamlmod/Manifest
new file mode 100644
index 00000000000..45f099751c5
--- /dev/null
+++ b/dev-ml/ocamlmod/Manifest
@@ -0,0 +1,2 @@
+DIST ocamlmod-0.0.3.tar.gz 43107 SHA256 23740d023c38b0aa8d8010d8df3ba69b1b93a5c5ebdd5ef5058ced18f88cbb70 SHA512 5a3761e43a468b8e391a6559538b23dd9f264ae46d7281445bec8797b1967d425c5b3fe26e72499c5947dfa23fb574ada033a2851167fdf3732a089964de4ef6 WHIRLPOOL 150e9a79d7415d31038f3692d70de3eb6256b54442d825f6f3b9c743ca9e1001538c07f0ecaef46f029b5cf239b2951c435d33d4ed7d36487549811c674c172a
+DIST ocamlmod-0.0.7.tar.gz 46221 SHA256 a329a0919fa18128b48fd00897204d2aecec0c946c1956541589f807203f6f86 SHA512 bc88dcccc3cae0506a17bcfc0e178ba26e3b6d634c47e704621198ff7f1920852163fb017f04b9d2d2add19235f3a29a3fa2f894189329e6629694953a8e1b15 WHIRLPOOL e28827069b256c0aac0f1a935bcc741dd0be0b48d6da3bdd2fd3eb701f434863b87f76b20adff079324bdde8f4e66e578ef622693ad61a5d25561f0df8f2229c
diff --git a/dev-ml/ocamlmod/metadata.xml b/dev-ml/ocamlmod/metadata.xml
new file mode 100644
index 00000000000..2193d772e35
--- /dev/null
+++ b/dev-ml/ocamlmod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlmod/ocamlmod-0.0.3.ebuild b/dev-ml/ocamlmod/ocamlmod-0.0.3.ebuild
new file mode 100644
index 00000000000..903fea8fd02
--- /dev/null
+++ b/dev-ml/ocamlmod/ocamlmod-0.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Generate OCaml modules from source files"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocamlmod/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/856/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+# test? ( >=dev-ml/ounit-1.1.1 )"
+
+DOCS=( "AUTHORS.txt" "README.txt" )
diff --git a/dev-ml/ocamlmod/ocamlmod-0.0.7.ebuild b/dev-ml/ocamlmod/ocamlmod-0.0.7.ebuild
new file mode 100644
index 00000000000..aeafb3f0508
--- /dev/null
+++ b/dev-ml/ocamlmod/ocamlmod-0.0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Generate OCaml modules from source files"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocamlmod/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1350/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+# test? ( >=dev-ml/ounit-2.0.0 )"
+
+DOCS=( "AUTHORS.txt" "README.txt" )