summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlpam
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-29 13:54:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-29 16:05:22 +0100
commit2c552c8ceb02f26d20454c1e050e24eca4fae890 (patch)
tree5f33bb555298f19156a049c97aa4aa1889d2985d /dev-ml/ocamlpam
parentb16ff5e76b8aa2daf85deddf3eba603c8e263a80 (diff)
downloadgentoo-2c552c8ceb02f26d20454c1e050e24eca4fae890.tar.gz
gentoo-2c552c8ceb02f26d20454c1e050e24eca4fae890.tar.xz
dev-ml/ocamlpam: fix build with ocaml 4.04
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ml/ocamlpam')
-rw-r--r--dev-ml/ocamlpam/files/ocaml404.patch12
-rw-r--r--dev-ml/ocamlpam/ocamlpam-1.1.ebuild3
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-ml/ocamlpam/files/ocaml404.patch b/dev-ml/ocamlpam/files/ocaml404.patch
new file mode 100644
index 00000000000..4964edf951f
--- /dev/null
+++ b/dev-ml/ocamlpam/files/ocaml404.patch
@@ -0,0 +1,12 @@
+Index: ocamlpam-1.1/pam_stubs.c
+===================================================================
+--- ocamlpam-1.1.orig/pam_stubs.c
++++ ocamlpam-1.1/pam_stubs.c
+@@ -57,6 +57,7 @@ static int converse(int nMsg, const stru
+ struct pam_response * local_responses;
+ caml_pam_handle * h;
+
++ CAMLparam0 ();
+ CAMLlocal1(ret);
+
+ h = (caml_pam_handle *)data;
diff --git a/dev-ml/ocamlpam/ocamlpam-1.1.ebuild b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
index b2b67cd9ac2..79a0e96e923 100644
--- a/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
+++ b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -21,6 +21,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-makefile.patch"
+ has_version '>=dev-lang/ocaml-4.04_beta' && epatch "${FILESDIR}/ocaml404.patch"
}
src_compile() {