summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlsdl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocamlsdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocamlsdl')
-rw-r--r--dev-ml/ocamlsdl/Manifest1
-rw-r--r--dev-ml/ocamlsdl/files/ocamlopt.patch22
-rw-r--r--dev-ml/ocamlsdl/metadata.xml8
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild64
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-ml/ocamlsdl/Manifest b/dev-ml/ocamlsdl/Manifest
new file mode 100644
index 00000000000..77f328fc865
--- /dev/null
+++ b/dev-ml/ocamlsdl/Manifest
@@ -0,0 +1 @@
+DIST ocamlsdl-0.9.1.tar.gz 226085 SHA256 abfb295b263dc11e97fffdd88ea1a28b46df8cc2b196777093e4fe7f509e4f8f SHA512 8be444a3a4d1b56919c7a28fb607cbd33446f8cf30de3768a9926f23f86690d98ebb8ce6f2fb28c167ea76ac138b670283c5c93d72ea2565aa49a0dc92de181a WHIRLPOOL f9bf44f6d63626bbae3621100b7ed19ad6eaf392f1e9d2ef39440b17ac279b92a5156bff9cf432e3241fd5ec2419a7f002602405d13d6fb1b0bdbcd0baf233d8
diff --git a/dev-ml/ocamlsdl/files/ocamlopt.patch b/dev-ml/ocamlsdl/files/ocamlopt.patch
new file mode 100644
index 00000000000..603654dceff
--- /dev/null
+++ b/dev-ml/ocamlsdl/files/ocamlopt.patch
@@ -0,0 +1,22 @@
+Index: ocamlsdl-0.9.1/src/Makefile
+===================================================================
+--- ocamlsdl-0.9.1.orig/src/Makefile
++++ ocamlsdl-0.9.1/src/Makefile
+@@ -17,7 +17,7 @@ gfx_MODULES = sdlgfx
+
+ TARGETS = sdl.cma $(patsubst %,sdl%.cma,$(PARTS))
+ TARGETS += libsdlstub.$(A) $(patsubst %,libsdl%stub.$(A),$(PARTS))
+-ifdef OCAMLOPT
++ifneq ($(OCAMLOPT),no)
+ TARGETS += sdl.cmxa $(patsubst %,sdl%.cmxa,$(PARTS))
+ endif
+
+@@ -87,7 +87,7 @@ ifdef OCAMLFIND
+ install-findlib :
+ $(OCAMLFIND) install sdl ../META \
+ *.cma lib*.$(A) *.cmi *.mli \
+- $(if $(OCAMLOPT),*.cmxa sdl*.$(A) *.cmx) \
++ $(if $(filter-out $(OCAMLOPT),no),*.cmxa sdl*.$(A) *.cmx) \
+ $(if $(OCAMLMKLIB),dll*.so)
+ ifeq ($(PLATFORM),Apple)
+ $(RANLIB) $$($(OCAMLFIND) printconf destdir)/sdl/*.$(A)
diff --git a/dev-ml/ocamlsdl/metadata.xml b/dev-ml/ocamlsdl/metadata.xml
new file mode 100644
index 00000000000..1f4835fdab3
--- /dev/null
+++ b/dev-ml/ocamlsdl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="sourceforge">ocamlsdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
new file mode 100644
index 00000000000..7b609fd7b9d
--- /dev/null
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml SDL Bindings"
+
+HOMEPAGE="http://ocamlsdl.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ppc x86"
+IUSE="doc +ocamlopt opengl truetype" #noimage nomixer
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt=]
+ >=media-libs/libsdl-1.2
+ opengl? ( >=dev-ml/lablgl-0.98:= )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ truetype? ( >=media-libs/sdl-ttf-2.0 )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/ocamlopt.patch"
+}
+
+src_configure() {
+ myconf=""
+ if use opengl; then
+ destdir=`ocamlfind printconf destdir`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ if [ -z "${lablgldir}" ]; then
+ destdir=`ocamlc -where`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ fi
+
+ if [ ! -z "${lablgldir}" ]; then
+ myconf="--with-lablgldir=${lablgldir}"
+ fi
+ fi
+
+ #use noimage && myconf="${myconf} --without-sdl-image"
+ #use nomixer && myconf="${myconf} --without-sdl-mixer"
+
+ econf $myconf \
+ `use_enable truetype sdl-ttf`
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc AUTHORS NEWS README
+ doinfo doc/*.info*
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}