summaryrefslogtreecommitdiff
path: root/dev-ml/odns/odns-0.3-r1.ebuild
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-10-16 14:17:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-16 17:10:15 +0200
commit873e1d671d1bf5da6a09e3fc8089cb1cde3f3663 (patch)
treef5911b26e0e3b8d8c2135ebab88be6cc2653c236 /dev-ml/odns/odns-0.3-r1.ebuild
parent01bc2277306537769a0e5f63f94904a9352be1c1 (diff)
downloadgentoo-873e1d671d1bf5da6a09e3fc8089cb1cde3f3663.tar.gz
gentoo-873e1d671d1bf5da6a09e3fc8089cb1cde3f3663.tar.xz
dev-ml/odns: revision bump
Makes sure odns doesn't get installed alongside ocaml-dns.
Diffstat (limited to 'dev-ml/odns/odns-0.3-r1.ebuild')
-rw-r--r--dev-ml/odns/odns-0.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/odns/odns-0.3-r1.ebuild b/dev-ml/odns/odns-0.3-r1.ebuild
new file mode 100644
index 00000000000..0b3b02fea7f
--- /dev/null
+++ b/dev-ml/odns/odns-0.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml library to query DNS servers"
+HOMEPAGE="http://odns.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It is ancient and upstream is dead. Consider using ocaml-dns instead.
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt]
+ !dev-ml/ocaml-dns
+"
+DEPEND="${RDEPEND}"
+
+CLIBS="" # Workaround for bug #422683
+
+src_prepare() {
+ sed -i -e "s/version=\"0.2\"/version=\"${PV}\"/" META || die
+ epatch "${FILESDIR}/${P}-parmake.patch"
+}
+
+src_compile() {
+ emake -j1 #453434
+}
+
+src_install() {
+ findlib_src_preinst
+ PREFIX="${D}/usr" emake install
+ dodoc AUTHORS README
+}