summaryrefslogtreecommitdiff
path: root/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-19 15:54:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-19 16:01:21 +0100
commitdcdfa0d2f754f211e4c038648cf06c75a83794d3 (patch)
tree5f131562f3623d0394c1533453c7ff87d1af3901 /dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
parentd1a2e1090a19bba04aeef0136648b7336b5081f8 (diff)
downloadgentoo-dcdfa0d2f754f211e4c038648cf06c75a83794d3.tar.gz
gentoo-dcdfa0d2f754f211e4c038648cf06c75a83794d3.tar.xz
dev-ml/postgresql-ocaml: bump to 3.2.2
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
new file mode 100644
index 00000000000..3f2ac2fec70
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}