summaryrefslogtreecommitdiff
path: root/dev-ml/postgresql-ocaml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-15 16:38:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-15 16:42:31 +0100
commit00d0da57195719227aa38783a58050a8347e216a (patch)
tree0bddb961f540531555f1a20925432a055449870f /dev-ml/postgresql-ocaml
parentd526fe71f108586f62e2efc2ef06a67321d22216 (diff)
downloadgentoo-00d0da57195719227aa38783a58050a8347e216a.tar.gz
gentoo-00d0da57195719227aa38783a58050a8347e216a.tar.xz
dev-ml/postgresql-ocaml: bump to 4.0.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/Manifest1
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/Manifest b/dev-ml/postgresql-ocaml/Manifest
index ccc5365ee0e..465975e7cb5 100644
--- a/dev-ml/postgresql-ocaml/Manifest
+++ b/dev-ml/postgresql-ocaml/Manifest
@@ -1,2 +1,3 @@
DIST postgresql-ocaml-2.0.5.tar.gz 79123 SHA256 e786c46edbd63aacd82e008098a2c801f445d59a29bd49713eae5cf5c157eaa8 SHA512 1d4b09b9135e1d6a98295bd51175ac44e6b51219703ad8ba5c0d429d81534989b43ed8922eff6511de4fc31b6dde1e6ca4f7bea91981e3d8c025d151258e41c7 WHIRLPOOL 04ae6fb1865fea75f286faf366ba4a976f260c502de1f898b48c8fb93b70ddedfdeeb9383e54efb2dd3b15e9b6d5302e1a5e0009188d8d83bbd69d4448774eef
DIST postgresql-ocaml-3.2.2.tar.gz 85697 SHA256 51348110f06e7d17f68894fd91f91b3e1f935647355a94a79b8c16f923ce9e81 SHA512 c41c6feed76d8d49932399a080d2e2fa9227b742e0cab5efdf849315ae1b633369e035bee3fd1d94c6a61e533f23d3881e9de650d1b4ec01946660f39c245917 WHIRLPOOL c314346cf113c87ceec3ded469505952a7717f06bdc6099e5fab84d4b5911927b611036bf924c9fdadb35c545ad3fc8ab06d115fd24ad78e045580ba8e02a04f
+DIST postgresql-ocaml-4.0.1.tar.gz 85871 SHA256 07d8fdb5c161b30809876375c43ebf29e5b99a475ee6b019b6fee3a80c18a4cb SHA512 baecd1b3b98f790131972dbd2eba563b43dec6e13e37ab904ee38b2b1168b03533272532887a42a2536806951c9e543306c6eccfb441de517ee860383ea5df36 WHIRLPOOL 71562d46b8688b4319f6fae06aeaea866e397cf6ce9f533b096d8d9f0850b2746fdffca6f4f234cc23cfb433d8124f559f89971d32554a756e88234c5a311e6d
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
new file mode 100644
index 00000000000..3f2ac2fec70
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}