summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_assert
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 18:57:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commite491d6d2cf03e73ddd4089b5a63024f2a30ff32b (patch)
tree47fde488bce565936de25cc400c9574e6079032f /dev-ml/ppx_assert
parenta6be2071cc51482fa7ea936365bf792906c184e3 (diff)
downloadgentoo-e491d6d2cf03e73ddd4089b5a63024f2a30ff32b.tar.gz
gentoo-e491d6d2cf03e73ddd4089b5a63024f2a30ff32b.tar.xz
dev-ml/ppx_assert: use proper install method
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_assert')
-rw-r--r--dev-ml/ppx_assert/ppx_assert-113.24.00.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-ml/ppx_assert/ppx_assert-113.24.00.ebuild b/dev-ml/ppx_assert/ppx_assert-113.24.00.ebuild
index 7592ff40d6d..92e351d92e3 100644
--- a/dev-ml/ppx_assert/ppx_assert-113.24.00.ebuild
+++ b/dev-ml/ppx_assert/ppx_assert-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Optional compilation for OCaml"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -28,14 +27,20 @@ DEPEND="dev-ml/ppx_tools:=
RDEPEND="${DEPEND}"
DEPEND="${RDEPEND} dev-ml/oasis"
-S="${WORKDIR}/${MY_P}"
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
-DOCS=( CHANGES.md )
+src_compile() {
+ emake
+}
-src_prepare() {
- sed -i -e 's/[.]expander/_expander/' _oasis || die
- sed -i -e 's/driver[.]ocamlbuild/driver_ocamlbuild/' _oasis || die
- sed -i -e "s/Executable ppx/Executable ${PN}/" _oasis || die
- rm -f _tags
- oasis setup || die
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
}