summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_core
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:36:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:06:58 +0100
commit86851a2158594601b49c95269e1f98d862db108d (patch)
tree4744103b5b4b9a041f715d655a6ab2171a7826e4 /dev-ml/ppx_core
parent8afa2de7374a27d14a807892a62ee798195f3e9e (diff)
downloadgentoo-86851a2158594601b49c95269e1f98d862db108d.tar.gz
gentoo-86851a2158594601b49c95269e1f98d862db108d.tar.xz
dev-ml/ppx_core: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_core')
-rw-r--r--dev-ml/ppx_core/Manifest1
-rw-r--r--dev-ml/ppx_core/ppx_core-113.33.00.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ppx_core/Manifest b/dev-ml/ppx_core/Manifest
index 12f8f377567..395b82ca4d0 100644
--- a/dev-ml/ppx_core/Manifest
+++ b/dev-ml/ppx_core/Manifest
@@ -1 +1,2 @@
DIST ppx_core-113.24.00.tar.gz 80849 SHA256 aa67133ad9a9fd28214bd073ed50b22d4b26748d9b35cc378684cc09312843f8 SHA512 d88d440aeea6892a8ffeb9314d1745d100afce5504d2d4d73954b36869ed1266add6d92fdcfa473a2a8d6f0877b3a721a57e2c5748f154e22320578219d1cf4a WHIRLPOOL 675ce05fe7d408709175afbef75b76dd9e0ece2912df6b173cf371019feff6e903b5231cfadbf2dc9b239378459e7f7ab393a1892253fd55f2b60279e860fb9a
+DIST ppx_core-113.33.00.tar.gz 81206 SHA256 460e052c82b954506aead3b1102f8342954013642acbf81b75f0b5a53fb45e1c SHA512 bf4e4720f14bc8c23b7d517bccd2ef2894099bafbfa5c0e9adb70fd7881ac81787c0500050edd94716c32fd0f3e71d7f9c5e3d0e500c967c4feaeaa2db9fc924 WHIRLPOOL 3da6f5477f9b395bc5d31d208b120c696d9e30eaf606677ecdceeb2be07920d59681406acb06f0404e6db981601037137a5323424c0284b54dc8f28ddf21ece6
diff --git a/dev-ml/ppx_core/ppx_core-113.33.00.ebuild b/dev-ml/ppx_core/ppx_core-113.33.00.ebuild
new file mode 100644
index 00000000000..d00d0966dd8
--- /dev/null
+++ b/dev-ml/ppx_core/ppx_core-113.33.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}