summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-22 10:15:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-22 10:31:39 +0200
commitb9ae1f00cd2039487325fdd83a117d4d2d9898eb (patch)
tree1180c56c3f325bc76fac9e617bcf203a9d4d2f91 /dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
parentc567658d3d151388a97364ae0fac3477bb782f3d (diff)
downloadgentoo-b9ae1f00cd2039487325fdd83a117d4d2d9898eb.tar.gz
gentoo-b9ae1f00cd2039487325fdd83a117d4d2d9898eb.tar.xz
dev-ml/ppx_custom_printf: update to opam.eclass
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
new file mode 100644
index 00000000000..0ed35963b46
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-0.9.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="https://github.com/janestreet/ppx_custom_printf"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_traverse
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/jbuilder"