summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-17 21:09:30 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-17 22:08:07 +0100
commitac562b67497585f9aedfcf9652a54a2cd2d7be89 (patch)
tree9d7eb572dbdd0ee82f5eb168e8a45c15da92d29a /dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild
parent38d84cce8a1f286a43421f5ff7a2067ad95fcaa3 (diff)
downloadgentoo-ac562b67497585f9aedfcf9652a54a2cd2d7be89.tar.gz
gentoo-ac562b67497585f9aedfcf9652a54a2cd2d7be89.tar.xz
dev-ml/ppx_deriving: bump to 3.1
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild b/dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild
new file mode 100644
index 00000000000..0099ce56db7
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/whitequark/ppx_deriving"
+SRC_URI="https://github.com/whitequark/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt test"
+
+DEPEND="dev-ml/ppx_tools:=
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ cp pkg/META.in pkg/META || die
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+ use doc && emake doc
+}
+
+src_test() {
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.byte -- || die
+ if use ocamlopt; then
+ ocamlbuild -j 0 -use-ocamlfind -classic-display \
+ src_test/test_ppx_deriving.native -- || die
+ fi
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ mv "${ED}/usr/lib/ppx_deriving/ppx_deriving" "${D}/$(ocamlc -where)/ppx_deriving/" || die
+
+ use doc && dohtml api.docdir/*
+
+ dodoc CHANGELOG.md README.md
+}