summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 17:31:44 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit4e207a3b51c0b590ab1662a018413494f75f00d7 (patch)
tree67edcb17a44ff40b57369ac2de542f1d5a04ed66 /dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
parent621e3ccef1b99d7649e778ce587d6cb01a96ae9a (diff)
downloadgentoo-4e207a3b51c0b590ab1662a018413494f75f00d7.tar.gz
gentoo-4e207a3b51c0b590ab1662a018413494f75f00d7.tar.xz
dev-ml/ppx_inline_test: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild b/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
new file mode 100644
index 00000000000..99e957577c8
--- /dev/null
+++ b/dev-ml/ppx_inline_test/ppx_inline_test-113.24.00.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension for writing in-line tests in ocaml code"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_core:="
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.md )