summaryrefslogtreecommitdiff
path: root/dev-ml/rresult
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-06 14:07:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 14:30:27 +0200
commit70f3de407f8762577eadfb7ecc300980d80219ba (patch)
treef04056e90e10443576578cf2ff2dc7a0d8c6d3dc /dev-ml/rresult
parent6498f607aaef23fd2d311d310dc86bc6f46d85a1 (diff)
downloadgentoo-70f3de407f8762577eadfb7ecc300980d80219ba.tar.gz
gentoo-70f3de407f8762577eadfb7ecc300980d80219ba.tar.xz
dev-ml/rresult: convert to opam.eclass
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/rresult')
-rw-r--r--dev-ml/rresult/rresult-0.5.0.ebuild16
1 files changed, 3 insertions, 13 deletions
diff --git a/dev-ml/rresult/rresult-0.5.0.ebuild b/dev-ml/rresult/rresult-0.5.0.ebuild
index 5078c39a985..85613f2d372 100644
--- a/dev-ml/rresult/rresult-0.5.0.ebuild
+++ b/dev-ml/rresult/rresult-0.5.0.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit opam
+
DESCRIPTION="Result value combinators for OCaml"
HOMEPAGE="http://erratique.ch/software/rresult https://github.com/dbuenzli/rresult"
SRC_URI="http://erratique.ch/software/rresult/releases/${P}.tbz"
@@ -12,23 +14,11 @@ SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND="
- dev-lang/ocaml:=
- dev-ml/result:=
-"
+RDEPEND="dev-ml/result:="
DEPEND="${RDEPEND}
dev-ml/topkg
- dev-ml/opam
dev-ml/ocamlbuild"
src_compile() {
ocaml pkg/pkg.ml build || die
}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
-}