summaryrefslogtreecommitdiff
path: root/dev-ml/typerep
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 17:55:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit2c96e2d9a583ac2b204b0585da5de5563f1d67db (patch)
tree4c7ae3cd59cdda9b92ebb928583dfab56fe9fe2a /dev-ml/typerep
parent73be3ab71665f3233492d864e9b8c642f4b6946b (diff)
downloadgentoo-2c96e2d9a583ac2b204b0585da5de5563f1d67db.tar.gz
gentoo-2c96e2d9a583ac2b204b0585da5de5563f1d67db.tar.xz
dev-ml/typerep: Fix install method and license
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/typerep')
-rw-r--r--dev-ml/typerep/typerep-113.24.00.ebuild24
1 files changed, 20 insertions, 4 deletions
diff --git a/dev-ml/typerep/typerep-113.24.00.ebuild b/dev-ml/typerep/typerep-113.24.00.ebuild
index c5f353aa6fc..2dff2b9df0c 100644
--- a/dev-ml/typerep/typerep-113.24.00.ebuild
+++ b/dev-ml/typerep/typerep-113.24.00.ebuild
@@ -6,12 +6,11 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Library for creating runtime representation of OCaml types"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-LICENSE="LGPL-2.1-with-linking-exception"
+LICENSE="Apache-2.0"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
@@ -21,5 +20,22 @@ DEPEND="
dev-ml/camlp4:="
RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
-S="${WORKDIR}/${MY_P}"
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}