summaryrefslogtreecommitdiff
path: root/dev-ml/zarith
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-09 10:20:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-09 10:20:00 +0200
commit2cb38bc42a2d5cea1a1fa428916aa0c0641d145f (patch)
tree37f99ad1d084dd0ba8a2183f0715f8893bdd051a /dev-ml/zarith
parent0063fdc9d99d25877ac39221247bb7b6b4831339 (diff)
downloadgentoo-2cb38bc42a2d5cea1a1fa428916aa0c0641d145f.tar.gz
gentoo-2cb38bc42a2d5cea1a1fa428916aa0c0641d145f.tar.xz
dev-ml/zarith: Skip tests when not building native code, they require it. Bug #624292
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/zarith-1.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/zarith/zarith-1.5.ebuild b/dev-ml/zarith/zarith-1.5.ebuild
index fcb766936ac..25bf4fad370 100644
--- a/dev-ml/zarith/zarith-1.5.ebuild
+++ b/dev-ml/zarith/zarith-1.5.ebuild
@@ -37,7 +37,11 @@ src_compile() {
}
src_test() {
- emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+ if use ocamlopt ; then
+ emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+ else
+ ewarn "Tests require USE=ocamlopt. Skipping them."
+ fi
}
src_install() {