summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-22 11:16:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-22 11:22:47 +0100
commit5d42443247ccf8b4990cebaaf22e6ac5f70cf68b (patch)
tree449e2e6e31c7daefce866ae7e7442c0dd9903faa /dev-ml
parent20f5efef0742620f10dd6b2ac50e6d7cb8b64603 (diff)
downloadgentoo-5d42443247ccf8b4990cebaaf22e6ac5f70cf68b.tar.gz
gentoo-5d42443247ccf8b4990cebaaf22e6ac5f70cf68b.tar.xz
dev-ml/ocaml-cstruct: bump to 1.9.0
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-1.9.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 38ea71ffcff..104f53acba3 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-cstruct-1.7.1.tar.gz 245894 SHA256 7869d096fe7c6231bbceefe3b2205417b28b6c10f4174b7e2cfdfa46956eaaa5 SHA512 67dd276ab2f895ef80cc7ba5b48d51bcfcf52ac49aa29cd4b17aa00be109198347a50229b81fbe506d831ace753d72f3b4bb80f19e8e57fa29d9ba65da472f19 WHIRLPOOL 8145930a1dcadbcf48c1da0dcba10a45f3d52c8ae2565aee7e609bd3eeb5eead9cee9ef423332a580ab77ceabb2f301917226d1a73e1b7f6efc7a3096c4112d6
DIST ocaml-cstruct-1.8.0.tar.gz 250696 SHA256 e1635072283ae5db7889966ce92e916749bcd192012a0c46285827beba1263d7 SHA512 38ea6301b48603f8b63c73a7aa42312d25bbd16fb8524e1de2b69a54e45e9e1c1326201e19fcf2953d2719607139c903d76296a32fb7058998c079ac112adc9c WHIRLPOOL 6fdabfc1143331662757826de11c62c3947fb59155ba68e866a2f9939963deacd52d5832417997833deff9a9ff902675d266a98b41e0d2cf9f29c4d4c628601e
+DIST ocaml-cstruct-1.9.0.tar.gz 254162 SHA256 2d175bf1e2cdc5ca43cb30bd3fa507beee2f18b2cbecae801ab6ffaecde16c9c SHA512 fad3788c0888599a3171d4062b9d9f4c539c0cbb1d8b6d4f6be2f3456ffe235444def4e619a94ca75336cf555b5133e6e60edc07a03dc0abdd772acf9371b666 WHIRLPOOL 99984c32625d9dbf452a7191f4103228bedbd7eee23bfb1eee7834022a023dee1582fca9704fcbe09ed37424ca7d684c482426d3b30b5f1dc66cc55b78769532
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.9.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.9.0.ebuild
new file mode 100644
index 00000000000..0589e77428a
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +camlp4 +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ camlp4? ( dev-ml/camlp4:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable camlp4)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )