summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 16:59:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:46 +0200
commit7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc (patch)
tree1f31b7f8f9a383372009a43d6b15ee58c835e6d9 /dev-ml
parent708249c0c3d83ab83f834c4e2981bae0bfd86537 (diff)
downloadgentoo-7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc.tar.gz
gentoo-7e8babd850f6bca379f8a5ba1d66ccb3e1dc06cc.tar.xz
dev-ml/bin-prot: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bin-prot/Manifest2
-rw-r--r--dev-ml/bin-prot/bin-prot-0.9.0.ebuild42
-rw-r--r--dev-ml/bin-prot/bin-prot-113.33.00.ebuild44
3 files changed, 43 insertions, 45 deletions
diff --git a/dev-ml/bin-prot/Manifest b/dev-ml/bin-prot/Manifest
index f9a2946b218..e050ff3bb2a 100644
--- a/dev-ml/bin-prot/Manifest
+++ b/dev-ml/bin-prot/Manifest
@@ -1 +1 @@
-DIST bin_prot-113.33.00.tar.gz 280362 SHA256 51cac973cce539e6ce3dfbafbe9dc631283d43b121e546c541b0578ca3213f5c SHA512 58772b0f56f6d4a09ded3a77d9f0b2e674b27ef387fb732bf682cd58cabc0c72d1dca0238d71b69f9576cc3105b41464a543154ea20854b20e8ed31e77599c09 WHIRLPOOL e652fc32f9de7ac0ecfdb3190eb54220ada631807907c17138da69f5a80d1d8ac4da1ff6b0bea8424e148a164e36d494dee3f64511572ef130089ad71db561aa
+DIST bin-prot-0.9.0.tar.gz 338958 SHA256 1fc88602788a802570ba81376a71dd76a1815b74ce80245e3fc4cfd7e259817e SHA512 111e0a9d07bdf22db6e3e7e9a165d196a264a3652e4cc363ec8f49c4ef385b8b76982a9d42fa8e0954e15a4a80c35ca6876c70fe6f20d7497fd8a2d53fab24c1 WHIRLPOOL 2d0fe47a957023d99bcde79146bef54c6e15801427db83697d16506d508231e95d6983f506502661740636ede95d2b36144c6d2f0953169785b27abe4d894764
diff --git a/dev-ml/bin-prot/bin-prot-0.9.0.ebuild b/dev-ml/bin-prot/bin-prot-0.9.0.ebuild
new file mode 100644
index 00000000000..c4b2b119856
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Binary protocol generator"
+HOMEPAGE="https://github.com/janestreet/bin_prot"
+SRC_URI="https://github.com/janestreet/bin_prot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/sexplib:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+S="${WORKDIR}/bin_prot-${PV}"
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN/-/_}.install || die
+ dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/bin-prot/bin-prot-113.33.00.ebuild b/dev-ml/bin-prot/bin-prot-113.33.00.ebuild
deleted file mode 100644
index ae3d4c5bbc2..00000000000
--- a/dev-ml/bin-prot/bin-prot-113.33.00.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-OASIS_BUILD_TESTS=1
-OASIS_BUILD_DOCS=1
-
-inherit oasis
-
-MY_P=${PN/-/_}-${PV}
-DESCRIPTION="A binary protocol generator"
-HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-RDEPEND=">=dev-ml/type-conv-109.28.00:="
-DEPEND="${RDEPEND}
- dev-ml/opam
- test? ( >=dev-ml/ounit-1.1.2 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN/-/_}.install || die
- dodoc CHANGES.md README.md
-}