summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:24:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:52 +0200
commitadf6d63aeed4050acca25d3882b9b60a09d34257 (patch)
tree1b4d9e42d8255ee853638ee3f9f8389e2b2fb5dd /dev-ml
parentca5384c29b916705ada1556c8124777157e67403 (diff)
downloadgentoo-adf6d63aeed4050acca25d3882b9b60a09d34257.tar.gz
gentoo-adf6d63aeed4050acca25d3882b9b60a09d34257.tar.xz
dev-ml/async: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/Manifest2
-rw-r--r--dev-ml/async/async-0.9.0.ebuild32
-rw-r--r--dev-ml/async/async-113.33.03.ebuild59
3 files changed, 33 insertions, 60 deletions
diff --git a/dev-ml/async/Manifest b/dev-ml/async/Manifest
index 96bd7236d37..05d1039ec8e 100644
--- a/dev-ml/async/Manifest
+++ b/dev-ml/async/Manifest
@@ -1 +1 @@
-DIST async-113.33.03.tar.gz 64087 SHA256 45787190030d21731a2f6c583f3117cdcd1ddf2a0118d16abd5304cda0772008 SHA512 ec8c609fe8b75e541433e39d745596cd39fe4a0327364ded895ceef339637efe6b517bc1901f9e9aff9f91b403e362d86dfad9877c6949315eec2e9c40ed456d WHIRLPOOL c30def8a8c11ad75c44e22209644fd193472aef5e6243e0c9bf5862e7044056a6b973310307532abba760cfe65ff3505109f3b9b767c1d32a956ebb1b98ea36a
+DIST async-0.9.0.tar.gz 17856 SHA256 7330548f896240e4f3a6e10b19a93a368fbb4f0104efe1845a37c5c5178640d4 SHA512 93c0fa4d6e7d1c4dff1f460db8ec95b3eea1d7c19fda117bb9efc8711f4908d2922467c33f66659395169ead9b37931da16a85a031d6073fc9296c218f2c55bb WHIRLPOOL 9c637ca96feac08f0c9b93dba1568724de2f26354c3180c6235102a99068113f8d5629b64bfc35f475ac867e736c70e6274d45ddf90bc3c19e064beed1109732
diff --git a/dev-ml/async/async-0.9.0.ebuild b/dev-ml/async/async-0.9.0.ebuild
new file mode 100644
index 00000000000..d64eaab2ead
--- /dev/null
+++ b/dev-ml/async/async-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="https://github.com/janestreet/async"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_extra:=
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/async/async-113.33.03.ebuild b/dev-ml/async/async-113.33.03.ebuild
deleted file mode 100644
index edafd66a668..00000000000
--- a/dev-ml/async/async-113.33.03.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="Jane Street Capital's asynchronous execution library"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-RDEPEND=">=dev-lang/ocaml-4.02.0:=
- >=dev-ml/async_kernel-113.33:=
- >=dev-ml/async_unix-113.33:=
- >=dev-ml/async_extra-113.33:=
- dev-ml/bin-prot:=
- dev-ml/core:=
- dev-ml/fieldslib:=
- dev-ml/ppx_assert:=
- dev-ml/ppx_bench:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_expect:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_jane:=
- dev-ml/sexplib:=
- dev-ml/typerep:=
- dev-ml/variantslib:=
-"
-DEPEND="${RDEPEND} dev-ml/opam"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}