summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-11 09:36:37 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-11 09:36:37 -0500
commitd34a7b7f850565813c58adfb6c1792af281928fb (patch)
treee91ada97a4900bae619438998fc10b148e8c92b9 /dev-ml
parent43731c08c9e73683b9d59f3fa4735e5f8c1adde4 (diff)
downloadgentoo-d34a7b7f850565813c58adfb6c1792af281928fb.tar.gz
gentoo-d34a7b7f850565813c58adfb6c1792af281928fb.tar.xz
dev-ml/ocaml-mysql: Revbump to fix dependencies and update EAPI
Bug: https://bugs.gentoo.org/665886 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild38
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild (renamed from dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild)10
2 files changed, 43 insertions, 5 deletions
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild
new file mode 100644
index 00000000000..74bddd8f624
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://ygrek.org.ua/p/release/ocaml-mysql/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ dev-db/mysql-connector-c:0="
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION
+}
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild
index a1afca457cf..87b9fd21e32 100644
--- a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2.ebuild
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit findlib eutils
+inherit findlib
IUSE="+ocamlopt"
@@ -13,7 +13,7 @@ HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
sys-libs/zlib
- >=virtual/mysql-4.0"
+ dev-db/mysql-connector-c:0="
RDEPEND="$DEPEND"
@@ -34,5 +34,5 @@ src_install()
findlib_src_preinst
emake install
- dodoc CHANGES README VERSION || die
+ dodoc CHANGES README VERSION
}