summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-30 17:19:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-30 17:30:40 +0100
commitf7786b74a481503746c66d8bb6d33b7fc0f348fd (patch)
treefaab6b56f48dda970d03d32e99c583299f4d5b23 /dev-ml
parent75debffc16b272fe48e28f897bb4d64784657336 (diff)
downloadgentoo-f7786b74a481503746c66d8bb6d33b7fc0f348fd.tar.gz
gentoo-f7786b74a481503746c66d8bb6d33b7fc0f348fd.tar.xz
dev-ml/reactiveData: bump to 0.2 and update homepage / src_uri
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/reactiveData/Manifest1
-rw-r--r--dev-ml/reactiveData/reactiveData-0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/reactiveData/Manifest b/dev-ml/reactiveData/Manifest
index c27121febf2..3e91283357e 100644
--- a/dev-ml/reactiveData/Manifest
+++ b/dev-ml/reactiveData/Manifest
@@ -1 +1,2 @@
DIST reactiveData-0.1.tar.gz 17074 SHA256 fc755843daaf3bdf1190d9fbfb63e760d4a0378dea2ae4da7b371b696c4cde14 SHA512 4c1d000d7c8713d365473e924ad22cc285a0d30009e4f3a4c23cb2fed9678209860cbfe9787b4aef24c9d1fe3b8bf2f71609e45bd52abdff5e27adc3afa651c0 WHIRLPOOL 4d9de7aca80f7ed6c1f83247170eec7289da9af2030f462a7a5bfe153d532621c1d1ec38dfd4237654da43694bd5972e55a44224513125117b2e7e24d725a95b
+DIST reactiveData-0.2.tar.gz 21063 SHA256 d80d425d2746ffc7bd1b88e9528b8236a5ca13cca636662dee1a59e96d675367 SHA512 ed6c82b499f7a740dcf3c39825dd9a98b73ab32d15159e372253a2ca9c8406301cd569654d02f5be2530b491b101587bb628984b0b6f1ce1cc21aab010e518cf WHIRLPOOL 819a6d999d84056967c34c9e451655b86840d30bf88903eb1a55bff41dbf552c6bac9dfa61b2d1a6c76c7806f6f61e307b27f382fc66ee7f380c2da5a4f72817
diff --git a/dev-ml/reactiveData/reactiveData-0.2.ebuild b/dev-ml/reactiveData/reactiveData-0.2.ebuild
new file mode 100644
index 00000000000..47f1e3c967b
--- /dev/null
+++ b/dev-ml/reactiveData/reactiveData-0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Functional reactive programming with incremental changes in data structures"
+HOMEPAGE="https://github.com/ocsigen/reactiveData"
+SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/react:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc README.md
+}