summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-LogFormat-Compiler
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Apache-LogFormat-Compiler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Apache-LogFormat-Compiler')
-rw-r--r--dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.320.0.ebuild40
-rw-r--r--dev-perl/Apache-LogFormat-Compiler/Manifest1
-rw-r--r--dev-perl/Apache-LogFormat-Compiler/metadata.xml5
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.320.0.ebuild b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.320.0.ebuild
new file mode 100644
index 00000000000..d5d4287eaa7
--- /dev/null
+++ b/dev-perl/Apache-LogFormat-Compiler/Apache-LogFormat-Compiler-0.320.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=KAZEBURO
+MODULE_VERSION=0.32
+
+inherit perl-module
+
+DESCRIPTION="Compile an Apache log format string to perl-code"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# POSIX -> perl
+RDEPEND="
+ >=dev-perl/POSIX-strftime-Compiler-0.300.0
+ virtual/perl-Time-Local
+ >=dev-lang/perl-5.8.4"
+
+# CPAN::Meta::Prereqs -> perl-CPAN-Meta
+# HTTP::Request::Common -> HTTP-Message
+# Test::More -> perl-Test-Simple
+# URI::Escape -> URI
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ virtual/perl-CPAN-Meta
+ test? (
+ dev-perl/HTTP-Message
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-Requires
+ >=dev-perl/Try-Tiny-0.120.0
+ >=dev-perl/URI-1.600.0
+ )
+"
+SRC_TEST="do parallel"
diff --git a/dev-perl/Apache-LogFormat-Compiler/Manifest b/dev-perl/Apache-LogFormat-Compiler/Manifest
new file mode 100644
index 00000000000..d77b7eaacdf
--- /dev/null
+++ b/dev-perl/Apache-LogFormat-Compiler/Manifest
@@ -0,0 +1 @@
+DIST Apache-LogFormat-Compiler-0.32.tar.gz 16354 SHA256 bc112cdbc32f2e93c10bf661f39de509036e01c20c3a702a22cdb0be4426dd7f SHA512 aee9443bd067dc9a623b8f694e3d0c8fd2d3b7e4fe6a547153eff0c2046f22a4503a9b999df2df92bee1eb06c17cbbe626555bd70018891784af51d7623ac27f WHIRLPOOL 00bfe93bab32fb1b9030b5016183ed152fb72ead46e441a49800d9588e417ad54d2ea90990a5aa0410ffbf419d56e75137cfe5ac1a845db8cd4c11838e50c9bb
diff --git a/dev-perl/Apache-LogFormat-Compiler/metadata.xml b/dev-perl/Apache-LogFormat-Compiler/metadata.xml
new file mode 100644
index 00000000000..36ee0f08c67
--- /dev/null
+++ b/dev-perl/Apache-LogFormat-Compiler/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+</pkgmetadata>