summaryrefslogtreecommitdiff
path: root/dev-perl/Cache-Cache
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Cache-Cache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Cache-Cache')
-rw-r--r--dev-perl/Cache-Cache/Cache-Cache-1.60.0-r1.ebuild24
-rw-r--r--dev-perl/Cache-Cache/Manifest1
-rw-r--r--dev-perl/Cache-Cache/metadata.xml28
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/Cache-Cache/Cache-Cache-1.60.0-r1.ebuild b/dev-perl/Cache-Cache/Cache-Cache-1.60.0-r1.ebuild
new file mode 100644
index 00000000000..eb6e08c24a9
--- /dev/null
+++ b/dev-perl/Cache-Cache/Cache-Cache-1.60.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JSWARTZ
+MODULE_VERSION=1.06
+inherit perl-module
+
+DESCRIPTION="Generic cache interface and implementations"
+
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 x86 ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-perl/Digest-SHA1-2.02
+ >=dev-perl/Error-0.15
+ >=virtual/perl-Storable-1.0.14
+ >=dev-perl/IPC-ShareLite-0.09"
+DEPEND="${RDEPEND}"
+
+export OPTIMIZE="$CFLAGS"
+SRC_TEST="do"
diff --git a/dev-perl/Cache-Cache/Manifest b/dev-perl/Cache-Cache/Manifest
new file mode 100644
index 00000000000..880ef3755cf
--- /dev/null
+++ b/dev-perl/Cache-Cache/Manifest
@@ -0,0 +1 @@
+DIST Cache-Cache-1.06.tar.gz 34506 SHA256 703d93793ab0b3bd984cfde89943ce1a98c0991f94afc9d1d531c752f52a4793 SHA512 db78376e049625dd1572386f2bc0dbc416569162f2ba997f584f3523a4be279ab67895cd16f51cd52bd160ab39d7225cb437786bbc52d66fa44fad15b501c85f WHIRLPOOL 9a631be52ac3daeec097c708dfbface080760999a53d94620c2c0a808cc6206eae3d4fc739dfb6f0d8b8b7b7a5d75184dc83ef51b1b2c400d327a5762acc3541
diff --git a/dev-perl/Cache-Cache/metadata.xml b/dev-perl/Cache-Cache/metadata.xml
new file mode 100644
index 00000000000..e49d246def3
--- /dev/null
+++ b/dev-perl/Cache-Cache/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Cache-Cache</remote-id>
+ <remote-id type="cpan-module">Cache::BaseCache</remote-id>
+ <remote-id type="cpan-module">Cache::BaseCacheTester</remote-id>
+ <remote-id type="cpan-module">Cache::Cache</remote-id>
+ <remote-id type="cpan-module">Cache::CacheMetaData</remote-id>
+ <remote-id type="cpan-module">Cache::CacheSizer</remote-id>
+ <remote-id type="cpan-module">Cache::CacheTester</remote-id>
+ <remote-id type="cpan-module">Cache::CacheUtils</remote-id>
+ <remote-id type="cpan-module">Cache::FileBackend</remote-id>
+ <remote-id type="cpan-module">Cache::FileCache</remote-id>
+ <remote-id type="cpan-module">Cache::MemoryBackend</remote-id>
+ <remote-id type="cpan-module">Cache::MemoryCache</remote-id>
+ <remote-id type="cpan-module">Cache::NullCache</remote-id>
+ <remote-id type="cpan-module">Cache::Object</remote-id>
+ <remote-id type="cpan-module">Cache::SharedMemoryBackend</remote-id>
+ <remote-id type="cpan-module">Cache::SharedMemoryCache</remote-id>
+ <remote-id type="cpan-module">Cache::SizeAwareCache</remote-id>
+ <remote-id type="cpan-module">Cache::SizeAwareCacheTester</remote-id>
+ <remote-id type="cpan-module">Cache::SizeAwareFileCache</remote-id>
+ <remote-id type="cpan-module">Cache::SizeAwareMemoryCache</remote-id>
+ <remote-id type="cpan-module">Cache::SizeAwareSharedMemoryCache</remote-id>
+ </upstream>
+</pkgmetadata>