summaryrefslogtreecommitdiff
path: root/dev-perl/DateTime/DateTime-1.420.0.ebuild
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-05 07:42:01 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-05 16:26:41 +1300
commit28b6c96deddd6f8b54f44bc7ace1bc00b2e44937 (patch)
tree1ff007a1ad25ae01eb22d6a61d624cc2bb14c17a /dev-perl/DateTime/DateTime-1.420.0.ebuild
parentbc00c75eaf780b859772ade22021b4f5d9b09a9a (diff)
downloadgentoo-28b6c96deddd6f8b54f44bc7ace1bc00b2e44937.tar.gz
gentoo-28b6c96deddd6f8b54f44bc7ace1bc00b2e44937.tar.xz
dev-perl/DateTime: Bump to version 1.420.0 ( masked )
Upstream: - add and subtract on Duration objects now also officially support Duration objects as their arguments. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/DateTime/DateTime-1.420.0.ebuild')
-rw-r--r--dev-perl/DateTime/DateTime-1.420.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/DateTime/DateTime-1.420.0.ebuild b/dev-perl/DateTime/DateTime-1.420.0.ebuild
new file mode 100644
index 00000000000..3c47fa61e4d
--- /dev/null
+++ b/dev-perl/DateTime/DateTime-1.420.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.42
+inherit perl-module
+
+DESCRIPTION="A date and time object"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+CONFLICTS="
+ !<=dev-perl/DateTime-Format-Mail-0.402.0
+"
+RDEPEND="
+ ${CONFLICTS}
+ virtual/perl-Carp
+ >=dev-perl/DateTime-Locale-1.60.0
+ >=dev-perl/DateTime-TimeZone-2.20.0
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Params-ValidationCompiler-0.130.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Specio-0.180.0
+ dev-perl/Try-Tiny
+ virtual/perl-XSLoader
+ >=dev-perl/namespace-autoclean-0.190.0
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-CPAN-Meta-Requirements
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"